summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb12
-rw-r--r--recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb12
-rw-r--r--recipes-demo-hmi/html5-hvac/html5-hvac_git.bb12
-rw-r--r--recipes-demo-hmi/html5-launcher/html5-launcher_git.bb12
-rw-r--r--recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb12
-rw-r--r--recipes-demo-hmi/html5-mixer/html5-mixer_git.bb2
-rw-r--r--recipes-demo-hmi/html5-settings/html5-settings_git.bb12
7 files changed, 7 insertions, 67 deletions
diff --git a/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb b/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
index 534bd2d3..ac874755 100644
--- a/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
+++ b/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
@@ -10,16 +10,6 @@ S = "${WORKDIR}/git/"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
inherit aglwgt
-
-do_configure() {
- cd ${B}
- npm install
-}
-
-do_aglwgt_package() {
- cd ${B}
- npm run build
-}
diff --git a/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb b/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb
index 68956263..37ca7073 100644
--- a/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb
@@ -10,16 +10,6 @@ S = "${WORKDIR}/git/"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
inherit aglwgt
-
-do_configure() {
- cd ${B}
- npm install
-}
-
-do_aglwgt_package() {
- cd ${B}
- npm run build
-}
diff --git a/recipes-demo-hmi/html5-hvac/html5-hvac_git.bb b/recipes-demo-hmi/html5-hvac/html5-hvac_git.bb
index d45dc80d..7fc89aed 100644
--- a/recipes-demo-hmi/html5-hvac/html5-hvac_git.bb
+++ b/recipes-demo-hmi/html5-hvac/html5-hvac_git.bb
@@ -10,16 +10,6 @@ S = "${WORKDIR}/git/"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
inherit aglwgt
-
-do_configure() {
- cd ${B}
- npm install
-}
-
-do_aglwgt_package() {
- cd ${B}
- npm run build
-}
diff --git a/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb b/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
index ce8a1d11..47760f67 100644
--- a/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
@@ -10,16 +10,6 @@ S = "${WORKDIR}/git/"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
inherit aglwgt
-
-do_configure() {
- cd ${B}
- npm install
-}
-
-do_aglwgt_package() {
- cd ${B}
- npm run build
-}
diff --git a/recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb b/recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb
index 2b143766..a87b9bcf 100644
--- a/recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb
+++ b/recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb
@@ -10,16 +10,6 @@ S = "${WORKDIR}/git/"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
inherit aglwgt
-
-do_configure() {
- cd ${B}
- npm install
-}
-
-do_aglwgt_package() {
- cd ${B}
- npm run build
-}
diff --git a/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb b/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb
index 09fa249b..97b1195c 100644
--- a/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb
+++ b/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb
@@ -10,6 +10,6 @@ S = "${WORKDIR}/git/"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
inherit aglwgt
diff --git a/recipes-demo-hmi/html5-settings/html5-settings_git.bb b/recipes-demo-hmi/html5-settings/html5-settings_git.bb
index dea1ec35..a167b142 100644
--- a/recipes-demo-hmi/html5-settings/html5-settings_git.bb
+++ b/recipes-demo-hmi/html5-settings/html5-settings_git.bb
@@ -10,16 +10,6 @@ S = "${WORKDIR}/git/"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-settings;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
inherit aglwgt
-
-do_configure() {
- cd ${B}
- npm install
-}
-
-do_aglwgt_package() {
- cd ${B}
- npm run build
-}