summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo/webapp-samples/files/webapps-examples.desktop11
-rw-r--r--recipes-demo/webapp-samples/html5-examples_git.bb11
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
3 files changed, 23 insertions, 0 deletions
diff --git a/recipes-demo/webapp-samples/files/webapps-examples.desktop b/recipes-demo/webapp-samples/files/webapps-examples.desktop
new file mode 100644
index 00000000..0764cfdc
--- /dev/null
+++ b/recipes-demo/webapp-samples/files/webapps-examples.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 Examples
+Comment=Examples of web contents
+GenericName=Examples
+Exec=/usr/bin/WebAppMgr --appid=webapps-examples --app-install-dir=/usr/lib/wam_apps/html5-examples/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/webapp-samples/html5-examples_git.bb b/recipes-demo/webapp-samples/html5-examples_git.bb
new file mode 100644
index 00000000..78537978
--- /dev/null
+++ b/recipes-demo/webapp-samples/html5-examples_git.bb
@@ -0,0 +1,11 @@
+SUMMARY = "AGL HTML5 Examples"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+DESKTOP_FILE = "webapps-examples.desktop"
+
+require webapp-samples.inc
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/examples/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 5fe6ec9e..cb2c912d 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -28,6 +28,7 @@ AGL_APPS = " \
html5-aquarium \
html5-youtube \
html5-jitsi \
+ html5-examples \
"
RDEPENDS:${PN}:append = " \