summaryrefslogtreecommitdiffstats
path: root/meta-agl-html5-demo
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-html5-demo')
-rw-r--r--meta-agl-html5-demo/recipes-core/nss/nss-agl-driver-db_git.bb7
-rw-r--r--meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb2
-rw-r--r--meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc2
-rw-r--r--meta-agl-html5-demo/recipes-wam/grpc-web-proxy/grpc-web-proxy_git.bb4
-rw-r--r--meta-agl-html5-demo/recipes-wam/wam/wam-cef.inc2
-rw-r--r--meta-agl-html5-demo/recipes-wam/wam/wam_git.bb4
6 files changed, 12 insertions, 9 deletions
diff --git a/meta-agl-html5-demo/recipes-core/nss/nss-agl-driver-db_git.bb b/meta-agl-html5-demo/recipes-core/nss/nss-agl-driver-db_git.bb
index b2fb40340..84cb34edc 100644
--- a/meta-agl-html5-demo/recipes-core/nss/nss-agl-driver-db_git.bb
+++ b/meta-agl-html5-demo/recipes-core/nss/nss-agl-driver-db_git.bb
@@ -11,6 +11,9 @@ SRC_URI = "file://${BPN}.service \
file://${BPN}.sh \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -22,8 +25,8 @@ do_install() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
install -d ${D}${sbindir}
- install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
- install -m 0755 ${WORKDIR}/${BPN}.sh ${D}${sbindir}
+ install -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
+ install -m 0755 ${UNPACKDIR}/${BPN}.sh ${D}${sbindir}
fi
}
diff --git a/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index 8638c7583..dfefd70f5 100644
--- a/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/meta-agl-html5-demo/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -33,7 +33,7 @@ SYSTEMD_SERVICE:${PN} = "homescreen.service"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -D -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+ install -D -m 0644 ${UNPACKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
}
FILES:${PN} = " \
diff --git a/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc b/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc
index 1a74a46c0..8bc93f53e 100644
--- a/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc
+++ b/meta-agl-html5-demo/recipes-demo/webapp-samples/webapp-samples.inc
@@ -15,7 +15,7 @@ WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install ${WORKDIR}/${APPINFO_FILE} ${D}${WAM_APPLICATIONS_DIR}/${PN}/appinfo.json
+ install ${UNPACKDIR}/${APPINFO_FILE} ${D}${WAM_APPLICATIONS_DIR}/${PN}/appinfo.json
}
FILES:${PN} = " \
diff --git a/meta-agl-html5-demo/recipes-wam/grpc-web-proxy/grpc-web-proxy_git.bb b/meta-agl-html5-demo/recipes-wam/grpc-web-proxy/grpc-web-proxy_git.bb
index dfb763b64..3c0f981f8 100644
--- a/meta-agl-html5-demo/recipes-wam/grpc-web-proxy/grpc-web-proxy_git.bb
+++ b/meta-agl-html5-demo/recipes-wam/grpc-web-proxy/grpc-web-proxy_git.bb
@@ -21,10 +21,10 @@ do_compile[network] = "1"
do_install:append() {
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/databroker-grpc-web-proxy.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${UNPACKDIR}/databroker-grpc-web-proxy.service ${D}${systemd_system_unitdir}
install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/databroker-grpc-web-proxy.env ${D}${sysconfdir}/default/databroker-grpc-web-proxy.env
+ install -m 0644 ${UNPACKDIR}/databroker-grpc-web-proxy.env ${D}${sysconfdir}/default/databroker-grpc-web-proxy.env
}
SYSTEMD_SERVICE:${PN} = "databroker-grpc-web-proxy.service"
diff --git a/meta-agl-html5-demo/recipes-wam/wam/wam-cef.inc b/meta-agl-html5-demo/recipes-wam/wam/wam-cef.inc
index f0fdcd35d..0bd01a0cd 100644
--- a/meta-agl-html5-demo/recipes-wam/wam/wam-cef.inc
+++ b/meta-agl-html5-demo/recipes-wam/wam/wam-cef.inc
@@ -31,7 +31,7 @@ EXTRA_OECMAKE = "\
do_install:append() {
cp -R --no-dereference --preserve=mode,links -v ${CEF_ROOT}/Release/* ${D}${WAM_OUT_DIR}
cp -R --no-dereference --preserve=mode,links -v ${CEF_ROOT}/Resources/* ${D}${WAM_OUT_DIR}
- install -v -D -m 644 ${WORKDIR}/WebAppMgr-cef.env ${D}${sysconfdir}/default/WebAppMgr.env
+ install -v -D -m 644 ${UNPACKDIR}/WebAppMgr-cef.env ${D}${sysconfdir}/default/WebAppMgr.env
sed -i -e 's#@WAM_EXE_DIR@#${WAM_OUT_DIR}#g' ${D}${systemd_system_unitdir}/WebAppMgr.service
}
diff --git a/meta-agl-html5-demo/recipes-wam/wam/wam_git.bb b/meta-agl-html5-demo/recipes-wam/wam/wam_git.bb
index f76641e51..9bfb1f98f 100644
--- a/meta-agl-html5-demo/recipes-wam/wam/wam_git.bb
+++ b/meta-agl-html5-demo/recipes-wam/wam/wam_git.bb
@@ -32,8 +32,8 @@ SYSTEMD_SERVICE:${PN} = "WebAppMgr.service"
do_install:append() {
install -v -d ${D}${sysconfdir}/wam
install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
- install -v -D -m 644 ${WORKDIR}/WebAppMgr.service ${D}${systemd_system_unitdir}/WebAppMgr.service
- install -v -D -m 755 ${WORKDIR}/WebAppMgrCli ${D}${bindir}/WebAppMgrCli
+ install -v -D -m 644 ${UNPACKDIR}/WebAppMgr.service ${D}${systemd_system_unitdir}/WebAppMgr.service
+ install -v -D -m 755 ${UNPACKDIR}/WebAppMgrCli ${D}${bindir}/WebAppMgrCli
}
CXXFLAGS:append:agl-devel = " -DAGL_DEVEL"