summaryrefslogtreecommitdiffstats
path: root/recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb')
-rw-r--r--recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb b/recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb
new file mode 100644
index 00000000..4a04ce13
--- /dev/null
+++ b/recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provide default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in low-can binding for the AGL demo setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.demo"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.demo ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"