summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/mediaplayer/mediaplayer_git.bb')
-rw-r--r--recipes-demo-hmi/mediaplayer/mediaplayer_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
new file mode 100644
index 00000000..c551e693
--- /dev/null
+++ b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Media Player for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating Media Player on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mediaplayer"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+# 'wgtpkg-pack' in af-main-native is required.
+DEPENDS = "af-main-native"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=http"
+SRCREV = "${AUTOREV}"
+
+RDEPENDS_${PN} += " \
+ qtmultimedia-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ "
+
+do_install() {
+ install -d ${D}/usr/AGL/apps
+ install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
+}
+
+FILES_${PN} += "/usr/AGL/apps/ \
+ /usr/AGL/apps/${PN} \
+ "