summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/ondemandnavi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/navigation/ondemandnavi_git.bb')
-rw-r--r--recipes-demo-hmi/navigation/ondemandnavi_git.bb50
1 files changed, 25 insertions, 25 deletions
diff --git a/recipes-demo-hmi/navigation/ondemandnavi_git.bb b/recipes-demo-hmi/navigation/ondemandnavi_git.bb
index 6cc26817..86ba5327 100644
--- a/recipes-demo-hmi/navigation/ondemandnavi_git.bb
+++ b/recipes-demo-hmi/navigation/ondemandnavi_git.bb
@@ -1,41 +1,41 @@
SUMMARY = "AGL Reference On Demand Navigation application."
-DESCRIPTION = "This application provides the function of Navigation to AGL. "
-HOMEPAGE = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
+DESCRIPTION = "Demo AGL navigation application based on QtLocation widget."
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
SECTION = "apps"
-LICENSE = "Apache-2.0"
+LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-inherit qmake5 aglwgt pkgconfig
+DEPENDS += "qtbase \
+ qtquickcontrols2 \
+ qlibhomescreen \
+ qlibwindowmanager \
+ qtlocation \
+ qtaglextras \
+"
-SRC_URI = "git://github.com/YoshitoMomiyama/aglqtnavigation.git;branch=master \
- file://0001-switch-to-alsa-output.patch \
- file://0002-update-permissions.patch \
- file://org.agl.naviapi.conf \
- "
-SRCREV = "a6930c2dff988e45e18f91a2368d829c08942b30"
-
-DEPENDS += " qtbase qtquickcontrols2 \
- qlibhomescreen \
- qlibwindowmanager \
- qtlocation qtaglextras \
- "
-
-RDEPENDS_${PN} += " qtlocation \
- flite \
- openjtalk \
- gstreamer1.0 \
- ondemandnavi-config \
- "
+PV = "1.0+git${SRCPV}"
-RPROVIDES_${PN} = "virtual/navigation"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH} \
+ file://org.agl.naviapi.conf \
+"
+SRCREV = "${AGL_APP_REVISION}"
S = "${WORKDIR}/git"
+inherit qmake5 aglwgt pkgconfig
+
do_install_append() {
install -d ${D}/etc/dbus-1/session.d/
install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
}
-PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+RDEPENDS_${PN} += "qtlocation \
+ flite \
+ openjtalk \
+ gstreamer1.0 \
+ ondemandnavi-config \
+"
+
+RPROVIDES_${PN} = "virtual/navigation"