summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb')
-rwxr-xr-xrecipes-demo-hmi/navigation/poiapp-api-key_1.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb b/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
new file mode 100755
index 00000000..ad6546fe
--- /dev/null
+++ b/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL Reference POI application API key."
+DESCRIPTION = "Preload the API key for the AGL POI application."
+HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
+SECTION = "apps"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+do_fetch[noexec] = "1"
+do_unpack[noexec] = "1"
+do_compile[noexec] = "1"
+
+POIAPP_API_KEY ?= ""
+
+do_install () {
+ install -d ${D}${sysconfdir}
+ echo "${POIAPP_API_KEY}" > ${D}${sysconfdir}/poikey
+}