summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/navigation')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer-demo.bb35
-rw-r--r--recipes-demo-hmi/navigation/mapviewer-demo/mapviewer-demo-network-conf.service15
-rw-r--r--recipes-demo-hmi/navigation/mapviewer-demo/weston-ready.conf4
3 files changed, 0 insertions, 54 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer-demo.bb b/recipes-demo-hmi/navigation/mapviewer-demo.bb
deleted file mode 100644
index 44f48049..00000000
--- a/recipes-demo-hmi/navigation/mapviewer-demo.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-SUMMARY = "Setting files of mapviewer for the AGL Demonstrator"
-DESCRIPTION = "Setting files of mapviewer for the AGL Demonstrator"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-SECTION = "apps"
-
-inherit systemd
-
-SRC_URI = " \
- file://weston-ready.conf \
- file://mapviewer-demo-network-conf.service \
-"
-
-do_install() {
- # Install cluster demo network configuration service unit
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/mapviewer-demo-network-conf.service ${D}${systemd_system_unitdir}
-
- # Add symlink to network.target.wants
- install -d ${D}${sysconfdir}/systemd/system/network.target.wants
- ln -s ${systemd_system_unitdir}/mapviewer-demo-network-conf.service ${D}${sysconfdir}/systemd/system/network.target.wants/
-
- # Workaround for now to ensure that the windowmanager and its dependencies
- # start after weston, which takes longer with gst-record enabled.
- # This should be investigated a bit further and likely reworked into
- # something more generically applicable.
- install -d ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
- install -m 0644 ${WORKDIR}/weston-ready.conf ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/xdg/weston/ \
- ${systemd_system_unitdir} \
-"
diff --git a/recipes-demo-hmi/navigation/mapviewer-demo/mapviewer-demo-network-conf.service b/recipes-demo-hmi/navigation/mapviewer-demo/mapviewer-demo-network-conf.service
deleted file mode 100644
index 1a6e2d8b..00000000
--- a/recipes-demo-hmi/navigation/mapviewer-demo/mapviewer-demo-network-conf.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=Configure dedicated link for cluster demo network
-After=sys-subsystem-net-devices-eth1.device
-Requires=sys-subsystem-net-devices-eth1.device
-Before=network.target
-
-[Service]
-# Note that this is done as opposed to using connman as configuring an
-# interface on a second network separate from the rest of the interfaces
-# is non-trivial in connman and needs further investigation.
-ExecStart=/sbin/ifconfig eth1 192.168.20.93
-Type=oneshot
-
-[Install]
-WantedBy=network.target
diff --git a/recipes-demo-hmi/navigation/mapviewer-demo/weston-ready.conf b/recipes-demo-hmi/navigation/mapviewer-demo/weston-ready.conf
deleted file mode 100644
index e90eed5f..00000000
--- a/recipes-demo-hmi/navigation/mapviewer-demo/weston-ready.conf
+++ /dev/null
@@ -1,4 +0,0 @@
-[Unit]
-Requires=weston-ready.service
-After=weston-ready.service
-