summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/radio/radio_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo-hmi/radio/radio_git.bb')
-rw-r--r--recipes-demo-hmi/radio/radio_git.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/recipes-demo-hmi/radio/radio_git.bb b/recipes-demo-hmi/radio/radio_git.bb
deleted file mode 100644
index 52a981f2..00000000
--- a/recipes-demo-hmi/radio/radio_git.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-SUMMARY = "Radio for CES2017 AGL Demonstration"
-DESCRIPTION = "AGL HMI Application for demonstrating Radio on AGL Distribution"
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/radio"
-SECTION = "apps"
-
-LICENSE = "Apache-2.0 & GPLv2+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
- file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;branch=${AGL_BRANCH} \
- file://presets-ALS.conf \
- file://presets-CES.conf \
- file://presets-FOSDEM.conf \
-"
-SRCREV = "${AGL_APP_REVISION}"
-
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
-
-# build-time dependencies
-DEPENDS = "qtquickcontrols2 rtl-sdr"
-DEPENDS += "libhomescreen qlibwindowmanager libqtappfw"
-
-inherit qmake5 aglwgt
-
-# ALS, CES, FOSDEM available
-AGL_RADIO_PRESETS_LOCALE ?= "CES"
-do_install_append() {
- install -d ${D}${sysconfdir}/xdg/AGL
- install -m 0644 ${WORKDIR}/presets-CES.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-CES.conf
- install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-ALS.conf
- install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-FOSDEM.conf
- install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
-}
-
-FILES_${PN} += "${sysconfdir}/xdg/AGL/*"
-
-RDEPENDS_${PN} += "agl-service-radio"