summaryrefslogtreecommitdiffstats
path: root/recipes-demo/agl-vss-helper/agl-vss-helper.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/agl-vss-helper/agl-vss-helper.bb')
-rw-r--r--recipes-demo/agl-vss-helper/agl-vss-helper.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/recipes-demo/agl-vss-helper/agl-vss-helper.bb b/recipes-demo/agl-vss-helper/agl-vss-helper.bb
index 88e14511a..be555dab8 100644
--- a/recipes-demo/agl-vss-helper/agl-vss-helper.bb
+++ b/recipes-demo/agl-vss-helper/agl-vss-helper.bb
@@ -8,6 +8,9 @@ SRC_URI = "file://agl-vss-helper.py \
file://agl-vss-helper.service \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -17,11 +20,11 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/${BPN}.py ${D}${sbindir}
+ install -m 0755 ${UNPACKDIR}/${BPN}.py ${D}${sbindir}
install -d ${D}${sysconfdir}/xdg/AGL/${BPN}
- install -m 0644 ${WORKDIR}/${BPN}.yaml ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/${BPN}.token ${D}${sysconfdir}/xdg/AGL/${BPN}/
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -m 0644 ${UNPACKDIR}/${BPN}.yaml ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/${BPN}.token ${D}${sysconfdir}/xdg/AGL/${BPN}/
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
RDEPENDS:${PN} = " \