summaryrefslogtreecommitdiffstats
path: root/recipes-demo/cluster-dashboard
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/cluster-dashboard')
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service6
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb10
2 files changed, 8 insertions, 8 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service b/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service
index d96c738b..de34e0a5 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service
@@ -6,9 +6,11 @@ After=agl-compositor.service
# Since we are part of the agl session, make sure we are started before
# it is complete.
-Before=agl-session.target
+Before=graphical.target
[Service]
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
ExecStart=/usr/bin/cluster-dashboard
Restart=always
@@ -17,4 +19,4 @@ StandardOutput=journal
StandardError=journal
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index dd463382..1404f671 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -26,14 +26,14 @@ SRCREV = "137144c447d8adb618f5acbcbafd65f50264d6eb"
S = "${WORKDIR}/git"
-inherit pkgconfig cmake_qt5
+inherit pkgconfig cmake_qt5 systemd
CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
do_install:append() {
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
- ln -s ../${BPN}.service ${D}${systemd_user_unitdir}/agl-session.target.wants/${BPN}.service
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
# VIS authorization token file for KUKSA.val should ideally not
# be readable by other users, but currently that's not doable
@@ -45,8 +45,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
-FILES:${PN} += " ${systemd_user_unitdir}"
-
RDEPENDS:${PN} += " \
qtwayland \
qtbase-qmlplugins \