summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/flutter-dashboard/flutter-dashboard_git.bb')
-rw-r--r--recipes-demo/flutter-dashboard/flutter-dashboard_git.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb b/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
new file mode 100644
index 00000000..d44b30c9
--- /dev/null
+++ b/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
@@ -0,0 +1,47 @@
+SUMMARY = "Flutter Dashboard"
+DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard"
+
+BUGTRACKER = "https://github.com/hritik-chouhan/dashboard_for_recipe/issues"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
+
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard;protocol=https;branch=${AGL_BRANCH} \
+ file://dashboard_config.yaml \
+ "
+
+SRCREV = "10945b8056eb2b228c156918a3505882a49a79b8"
+S = "${WORKDIR}/git"
+
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "dashboard_app"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "dashboard_app"
+AGL_APP_NAME = "Flutter Dashboard"
+
+
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/dashboard_config.yaml ${D}${sysconfdir}/xdg/AGL/
+
+
+
+}
+
+FILES:${PN} += "${sysconfdir}/xdg/AGL"
+