summaryrefslogtreecommitdiffstats
path: root/recipes-demo/launcher/launcher_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/launcher/launcher_git.bb')
-rw-r--r--recipes-demo/launcher/launcher_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-demo/launcher/launcher_git.bb b/recipes-demo/launcher/launcher_git.bb
new file mode 100644
index 00000000..5b1de013
--- /dev/null
+++ b/recipes-demo/launcher/launcher_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "AGL Launcher Application"
+DESCRIPTION = "AGL Launcher Application build with recipe method"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ qtwebsockets \
+ qlibhomescreen \
+ wayland-native \
+ wayland \
+ qtwayland \
+ qtwayland-native \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"