summaryrefslogtreecommitdiffstats
path: root/recipes-demo/navigation/ondemandnavi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/navigation/ondemandnavi_git.bb')
-rw-r--r--recipes-demo/navigation/ondemandnavi_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
new file mode 100644
index 00000000..c06dcae2
--- /dev/null
+++ b/recipes-demo/navigation/ondemandnavi_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "AGL Reference On Demand Navigation application."
+DESCRIPTION = "Demo AGL navigation application based on QtLocation widget."
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS += "qtquickcontrols2 \
+ qlibhomescreen \
+ qtlocation \
+ libqtappfw \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 aglwgt pkgconfig
+
+RDEPENDS_${PN} += "qtlocation \
+ flite \
+ libqtappfw \
+ openjtalk \
+ gstreamer1.0 \
+ ondemandnavi-config \
+"
+
+RPROVIDES_${PN} = "virtual/navigation"
+