summaryrefslogtreecommitdiffstats
path: root/recipes-demo/webapp-samples/html5-examples_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/webapp-samples/html5-examples_git.bb')
-rw-r--r--recipes-demo/webapp-samples/html5-examples_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-demo/webapp-samples/html5-examples_git.bb b/recipes-demo/webapp-samples/html5-examples_git.bb
new file mode 100644
index 00000000..c2b131af
--- /dev/null
+++ b/recipes-demo/webapp-samples/html5-examples_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "AGL HTML5 Examples"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+APPINFO_FILE = "appinfo-examples.json"
+
+require webapp-samples.inc
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-examples"
+AGL_APP_NAME = "Examples"
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/examples/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+