summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-anytree_2.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-anytree_2.8.0.bb')
-rw-r--r--recipes-devtools/python/python3-anytree_2.8.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-anytree_2.8.0.bb b/recipes-devtools/python/python3-anytree_2.8.0.bb
new file mode 100644
index 00000000..1b4628a9
--- /dev/null
+++ b/recipes-devtools/python/python3-anytree_2.8.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Powerful and Lightweight Python Tree Data Structure"
+HOMEPAGE = "https://github.com/c0fec0de/anytree"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+PYPI_PACKAGE = "anytree"
+
+SRC_URI[sha256sum] = "3f0f93f355a91bc3e6245319bf4c1d50e3416cc7a35cc1133c1ff38306bbccab"
+
+inherit pypi setuptools3
+
+do_install:append () {
+ rm -f ${D}${prefix}/LICENSE
+}
+
+BBCLASSEXTEND += "native nativesdk"