summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-qtpy_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-qtpy_2.4.0.bb')
-rw-r--r--recipes-devtools/python/python3-qtpy_2.4.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-qtpy_2.4.0.bb b/recipes-devtools/python/python3-qtpy_2.4.0.bb
new file mode 100644
index 00000000..8e454cb3
--- /dev/null
+++ b/recipes-devtools/python/python3-qtpy_2.4.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Abstraction layer for PyQt5/PySide2/PyQt6/PySide6"
+HOMEPAGE = "https://github.com/spyder-ide/qtpy"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b2830f54500be1314b9ec6096989f983"
+
+PYPI_PACKAGE = "QtPy"
+
+SRC_URI[sha256sum] = "db2d508167aa6106781565c8da5c6f1487debacba33519cedc35fa8997d424d4"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-pyqt5 \
+"