summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-setuptools-git-versioning_1.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-setuptools-git-versioning_1.7.4.bb')
-rw-r--r--recipes-devtools/python/python3-setuptools-git-versioning_1.7.4.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-setuptools-git-versioning_1.7.4.bb b/recipes-devtools/python/python3-setuptools-git-versioning_1.7.4.bb
new file mode 100644
index 00000000..698a3bb6
--- /dev/null
+++ b/recipes-devtools/python/python3-setuptools-git-versioning_1.7.4.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Use git repo data for building a version number according PEP-440"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f22e7cb81b49604c2450680982bdc067"
+PYPI_PACKAGE = "setuptools-git-versioning"
+
+DEPENDS = "python3-six-native"
+
+SRC_URI[sha256sum] = "be2901afcb7c865e3b500a38183598657fd029a1a72c8d1dfc7fbffb5c227dac"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-setuptools \
+ python3-six \
+"
+
+BBCLASSEXTEND = "native"