summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/sllin/sllin/0001-update-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/sllin/sllin/0001-update-makefile.patch')
-rw-r--r--recipes-kernel/sllin/sllin/0001-update-makefile.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/sllin/sllin/0001-update-makefile.patch b/recipes-kernel/sllin/sllin/0001-update-makefile.patch
new file mode 100644
index 00000000..7db57802
--- /dev/null
+++ b/recipes-kernel/sllin/sllin/0001-update-makefile.patch
@@ -0,0 +1,21 @@
+diff --git a/sllin/Makefile b/sllin/Makefile
+index 8ae7510..037846f 100644
+--- a/sllin/Makefile
++++ b/sllin/Makefile
+@@ -1,10 +1,11 @@
+ obj-m += sllin.o
+-KPATH=/lib/modules/$(shell uname -r)/build
++KPATH=$(KERNEL_SRC)
+ #KPATH=/mnt/data/_dokumenty_/_w_/_dce_can_/src/can-benchmark/kernel/build/shark/3.0.4
+ #KPATH=/mnt/data/_dokumenty_/_w_/_dce_can_/src/can-benchmark/kernel/build/shark/2.6.36
+-
++SRC := $(shell pwd)
+ all:
+- make -C ${KPATH} M=$(PWD) modules
+-
++ make -C ${KPATH} M=$(SRC) modules
++modules_install:
++ make -C ${KPATH} M=$(SRC) modules_install
+ clean:
+- make -C ${KPATH} M=$(PWD) clean
++ make -C ${KPATH} M=$(SRC) clean