summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-kvm-demo-platform.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-platform/images/agl-kvm-demo-platform.bb')
-rw-r--r--recipes-platform/images/agl-kvm-demo-platform.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-kvm-demo-platform.bb b/recipes-platform/images/agl-kvm-demo-platform.bb
index 4337ec02..338b3e6c 100644
--- a/recipes-platform/images/agl-kvm-demo-platform.bb
+++ b/recipes-platform/images/agl-kvm-demo-platform.bb
@@ -3,9 +3,16 @@ DESCRIPTION = "AGL KVM+QEMU Demo Platform image."
LICENSE = "MIT"
require recipes-platform/images/agl-image-compositor.bb
+require agl-demo-features.inc
IMAGE_FEATURES += "splash package-management ssh-server-openssh"
+# If building with "agl-kvm-host-kuksa", the databroker and likely
+# some clients run on the host
+IMAGE_FEATURES += " \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-kvm-host-kuksa", "kuksa-val-databroker kuksa-val-databroker-client", "", d)} \
+"
+
# Add packages for KVM+QEMU demo platform here
IMAGE_INSTALL += " \
packagegroup-agl-core-connectivity \