summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-platform/images')
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-flutter.bb9
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform.bb4
-rw-r--r--recipes-platform/images/agl-cluster-demo-qtcompositor.bb20
-rw-r--r--recipes-platform/images/agl-image-graphical-html5.bb19
-rwxr-xr-xrecipes-platform/images/agl-image-graphical-qt5-crosssdk.bb32
-rw-r--r--recipes-platform/images/agl-image-ivi-crosssdk.bb23
-rw-r--r--recipes-platform/images/agl-image-ivi.bb10
-rw-r--r--recipes-platform/images/agl-ivi-crosssdk.inc21
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb48
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-flutter.bb2
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-html5.bb2
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform.bb5
-rw-r--r--recipes-platform/images/agl-kvm-demo-platform.bb5
-rw-r--r--recipes-platform/images/agl-telematics-demo-platform.bb4
14 files changed, 54 insertions, 150 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
index bf3820aa..fc3cc51f 100644
--- a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
@@ -2,7 +2,7 @@ SUMMARY = "Baseline Flutter Image for Release"
LICENSE = "MIT"
-require recipes-platform/images/agl-image-weston.inc
+require recipes-platform/images/agl-image-compositor.bb
IMAGE_FEATURES += "splash package-management ssh-server-openssh"
@@ -21,12 +21,9 @@ IMAGE_KUKSA_PACKAGES = " \
"
# generic
-IMAGE_INSTALL:append = "\
- agl-compositor \
- agl-compositor-init \
+IMAGE_INSTALL += "\
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
\
- packagegroup-agl-profile-graphical \
packagegroup-agl-networking \
cluster-receiver \
\
@@ -35,7 +32,7 @@ IMAGE_INSTALL:append = "\
"
# Flutter
-IMAGE_INSTALL:append = "\
+IMAGE_INSTALL += "\
flutter-cluster-dashboard \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
cluster-demo-config-flutter \
diff --git a/recipes-platform/images/agl-cluster-demo-platform.bb b/recipes-platform/images/agl-cluster-demo-platform.bb
index 8a3b9a79..f0b04a6b 100644
--- a/recipes-platform/images/agl-cluster-demo-platform.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "AGL Cluster Demo Platform image currently contains a simple clust
LICENSE = "MIT"
-require recipes-platform/images/agl-image-boot.inc
+require recipes-platform/images/agl-image-compositor.bb
IMAGE_FEATURES += "splash package-management ssh-server-openssh"
@@ -11,7 +11,7 @@ inherit features_check
REQUIRED_DISTRO_FEATURES = "wayland"
# add packages for cluster demo platform (include demo apps) here
-IMAGE_INSTALL:append = " \
+IMAGE_INSTALL += " \
packagegroup-agl-cluster-demo-platform \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
diff --git a/recipes-platform/images/agl-cluster-demo-qtcompositor.bb b/recipes-platform/images/agl-cluster-demo-qtcompositor.bb
index a9da9763..69dee2df 100644
--- a/recipes-platform/images/agl-cluster-demo-qtcompositor.bb
+++ b/recipes-platform/images/agl-cluster-demo-qtcompositor.bb
@@ -1,23 +1,11 @@
DESCRIPTION = "AGL Cluster Demo Qtwayland Compositor image currently contains a \
-simple cluster interface and some AGL service."
+simple cluster interface."
LICENSE = "MIT"
-require recipes-platform/images/agl-image-boot.inc
+require recipes-platform/images/agl-image-weston.bb
IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
-inherit features_check
-
-REQUIRED_DISTRO_FEATURES = "wayland"
-
-# add packages for cluster demo qtcompositor
-IMAGE_INSTALL:append = " \
- packagegroup-agl-cluster-demo-qtcompositor \
-"
-
-# NOTE: This should be revisited after upgrading to hardknott or later,
-# as it may no longer be required. However, since Wayland is not
-# being used, the new "weston" image feature may not be a viable
-# option.
-SYSTEMD_DEFAULT_TARGET = "graphical.target"
+# Add packages for qtcompositor demo
+IMAGE_INSTALL += "cluster-gauges-qtcompositor"
diff --git a/recipes-platform/images/agl-image-graphical-html5.bb b/recipes-platform/images/agl-image-graphical-html5.bb
deleted file mode 100644
index c25a9275..00000000
--- a/recipes-platform/images/agl-image-graphical-html5.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "An image containing all packages required to run web applications"
-
-require recipes-platform/images/agl-image-minimal.inc
-
-IMAGE_FEATURES += "splash"
-
-IMAGE_FEATURES += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'ssh-server-dropbear' , '', d)}"
-
-inherit features_check
-
-REQUIRED_DISTRO_FEATURES = "wayland"
-
-
-LICENSE = "MIT"
-
-IMAGE_INSTALL:append = "\
- packagegroup-agl-profile-graphical-html5 \
- "
-
diff --git a/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb b/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb
deleted file mode 100755
index 596ac80e..00000000
--- a/recipes-platform/images/agl-image-graphical-qt5-crosssdk.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
-
-DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
-It includes the full meta-toolchain, plus developement headers and libraries \
-to form a standalone cross SDK."
-
-#require agl-image-graphical-qt5.bb
-require recipes-platform/images/agl-image-weston.inc
-
-
-LICENSE = "MIT"
-
-require recipes-platform/images/agl-image-minimal-crosssdk.inc
-
-# Add wayland-scanner to SDK (SPEC-945)
-# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
-# wayland-scanner is in nativesdk-wayland-dev !
-# option: add also nativesdk-qtwayland-tools
-TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
-
-TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
-
-# Add qtwaylandscanner to the SDK
-TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
-
-
-inherit populate_sdk populate_sdk_qt5
-
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
diff --git a/recipes-platform/images/agl-image-ivi-crosssdk.bb b/recipes-platform/images/agl-image-ivi-crosssdk.bb
index 2f722b21..be008832 100644
--- a/recipes-platform/images/agl-image-ivi-crosssdk.bb
+++ b/recipes-platform/images/agl-image-ivi-crosssdk.bb
@@ -1,20 +1,11 @@
-require recipes-platform/images/agl-image-minimal-crosssdk.inc
+require agl-image-ivi.bb
-require recipes-platform/images/agl-image-minimal.inc
+SUMMARY = "Cross SDK of minimal AGL Distribution for IVI profile"
-IMAGE_INSTALL:append = "\
- packagegroup-agl-image-ivi \
- packagegroup-agl-ivi-services \
- ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)} \
- can-utils \
- iproute2 \
- "
+DESCRIPTION = "SDK image for minimal AGL Distribution for IVI profile. \
+It includes the full toolchain, plus development headers and libraries \
+to form a standalone cross SDK."
-IMAGE_FEATURES += "splash package-management ssh-server-openssh"
+inherit agl-crosssdk
-inherit populate_sdk
-
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
+require agl-ivi-crosssdk.inc
diff --git a/recipes-platform/images/agl-image-ivi.bb b/recipes-platform/images/agl-image-ivi.bb
index b5cf0a54..41766514 100644
--- a/recipes-platform/images/agl-image-ivi.bb
+++ b/recipes-platform/images/agl-image-ivi.bb
@@ -4,22 +4,16 @@ DESCRIPTION = "Basic image for baseline of AGL Distribution for IVI profile."
LICENSE = "MIT"
-require recipes-platform/images/agl-image-weston.inc
+require recipes-platform/images/agl-image-compositor.bb
-IMAGE_INSTALL:append = "\
+IMAGE_INSTALL += " \
packagegroup-agl-image-ivi \
packagegroup-agl-ivi-services \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-agl-ivi-services-devel' , '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'wireplumber-config-agl wireplumber-policy-config-agl', '', d)} \
can-utils \
iproute2 \
"
IMAGE_FEATURES += "splash package-management ssh-server-openssh"
-# NOTE: In hardknott or later this can be replaced by adding "weston"
-# to IMAGE_FEATURES.
-SYSTEMD_DEFAULT_TARGET = "graphical.target"
-
diff --git a/recipes-platform/images/agl-ivi-crosssdk.inc b/recipes-platform/images/agl-ivi-crosssdk.inc
new file mode 100644
index 00000000..551c0343
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-crosssdk.inc
@@ -0,0 +1,21 @@
+#
+# Common IVI SDK configuration
+#
+# Only host tool additions should done here
+#
+
+# Add wayland-scanner to SDK (SPEC-945)
+# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
+# wayland-scanner is in nativesdk-wayland-dev !
+# option: add also nativesdk-qtwayland-tools
+TOOLCHAIN_HOST_TASK += "nativesdk-wayland nativesdk-wayland-dev"
+
+TOOLCHAIN_HOST_TASK += "nativesdk-perl-modules"
+
+# add grpc for building natively for grpc_cpp_plugin
+TOOLCHAIN_HOST_TASK += "nativesdk-grpc nativesdk-grpc-dev"
+
+# Add gcc-sanitizers to support building applications using the SDK with
+# AddressSanitizer support to detect use-after-frees along with other
+# memory issue.
+TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
diff --git a/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb b/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
index 3e3d478d..c9ed07a0 100644
--- a/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
@@ -1,50 +1,16 @@
require agl-ivi-demo-platform.bb
-SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
+SUMMARY = "Cross SDK of demo AGL Distribution for IVI profile"
DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
-It includes the full meta-toolchain, plus developement headers and libraries \
-to form a standalone cross SDK."
+It includes the full toolchain, plus development headers and libraries \
+for everything in the demo platform to form a standalone cross SDK."
-require recipes-platform/images/agl-image-minimal-crosssdk.inc
+inherit agl-crosssdk
-# Add wayland-scanner to SDK (SPEC-945)
-# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
-# wayland-scanner is in nativesdk-wayland-dev !
-# option: add also nativesdk-qtwayland-tools
-TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
+require agl-ivi-crosssdk.inc
-TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
+inherit populate_sdk_qt5
# Add qtwaylandscanner to the SDK
-TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
-
-# add grpc for building natively for grpc_cpp_plugin
-TOOLCHAIN_HOST_TASK:append = " nativesdk-grpc nativesdk-grpc-dev "
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
-
-inherit populate_sdk populate_sdk_qt5
-
-# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
-# Both exec "createrepo" on the same directory, and so one of them
-# can failed (randomly).
-addtask do_populate_sdk after do_rootfs
-
-# Add gcc-sanitizers to support building applications using the SDK with
-# AddressSanitizer support to detect use-after-frees along with other
-# memory issue.
-TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
-
-
-TOOLCHAIN_HOST_TASK += " \
- nativesdk-lua \
-"
-
-# Required dependencies for app and test builds
-TOOLCHAIN_TARGET_TASK += " \
- lua-dev \
- lua-staticdev \
-"
+TOOLCHAIN_HOST_TASK += "nativesdk-qtwayland-tools"
diff --git a/recipes-platform/images/agl-ivi-demo-platform-flutter.bb b/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
index f385c1e0..85f892fc 100644
--- a/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
@@ -6,7 +6,7 @@ require agl-demo-features.inc
require agl-demo-container-guest-integration.inc
# add packages for demo platform (include demo apps) here
-IMAGE_INSTALL:append = " \
+IMAGE_INSTALL += " \
packagegroup-agl-demo-platform-flutter \
weston-ini-conf-flutter \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
diff --git a/recipes-platform/images/agl-ivi-demo-platform-html5.bb b/recipes-platform/images/agl-ivi-demo-platform-html5.bb
index dc82ce4e..85d2ca05 100644
--- a/recipes-platform/images/agl-ivi-demo-platform-html5.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform-html5.bb
@@ -6,6 +6,6 @@ DESCRIPTION = "Contains the web runtime and sample web apps"
require agl-demo-container-guest-integration.inc
# add packages for demo platform (include demo apps) here
-IMAGE_INSTALL:append = " \
+IMAGE_INSTALL += " \
packagegroup-agl-demo-platform-html5 \
"
diff --git a/recipes-platform/images/agl-ivi-demo-platform.bb b/recipes-platform/images/agl-ivi-demo-platform.bb
index f5fcad91..a07fa2fa 100644
--- a/recipes-platform/images/agl-ivi-demo-platform.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform.bb
@@ -1,13 +1,12 @@
require agl-image-ivi.bb
-DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
-demos."
+DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and demos."
require agl-demo-features.inc
require agl-demo-container-guest-integration.inc
# add packages for demo platform (include demo apps) here
-IMAGE_INSTALL:append = " \
+IMAGE_INSTALL += " \
packagegroup-agl-demo-platform \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
"
diff --git a/recipes-platform/images/agl-kvm-demo-platform.bb b/recipes-platform/images/agl-kvm-demo-platform.bb
index 378ea832..4337ec02 100644
--- a/recipes-platform/images/agl-kvm-demo-platform.bb
+++ b/recipes-platform/images/agl-kvm-demo-platform.bb
@@ -2,13 +2,12 @@ DESCRIPTION = "AGL KVM+QEMU Demo Platform image."
LICENSE = "MIT"
-require recipes-platform/images/agl-image-weston.inc
+require recipes-platform/images/agl-image-compositor.bb
IMAGE_FEATURES += "splash package-management ssh-server-openssh"
# Add packages for KVM+QEMU demo platform here
-IMAGE_INSTALL:append = " \
- packagegroup-agl-image-minimal \
+IMAGE_INSTALL += " \
packagegroup-agl-core-connectivity \
kernel-image \
agl-compositor \
diff --git a/recipes-platform/images/agl-telematics-demo-platform.bb b/recipes-platform/images/agl-telematics-demo-platform.bb
index b8a99617..7a113b65 100644
--- a/recipes-platform/images/agl-telematics-demo-platform.bb
+++ b/recipes-platform/images/agl-telematics-demo-platform.bb
@@ -2,12 +2,12 @@ DESCRIPTION = "AGL Telematics Demo Platform image."
LICENSE = "MIT"
-require recipes-platform/images/agl-image-boot.inc
+require recipes-platform/images/agl-image-minimal.bb
inherit features_check
REQUIRED_DISTRO_FEATURES = "3g"
-IMAGE_INSTALL:append = " \
+IMAGE_INSTALL += " \
packagegroup-agl-telematics-demo-platform \
"