summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-platform/images')
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb16
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-html5.bb11
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform.bb10
3 files changed, 13 insertions, 24 deletions
diff --git a/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb b/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
index 45db0e30..03bc3c40 100644
--- a/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
@@ -1,19 +1,11 @@
+require agl-ivi-demo-platform.bb
+
SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
It includes the full meta-toolchain, plus developement headers and libraries \
to form a standalone cross SDK."
-
-require agl-image-ivi.bb
-
-# add packages for demo platform (include demo apps) here
-IMAGE_INSTALL:append = " \
- packagegroup-agl-demo-platform \
- "
-
-LICENSE = "MIT"
-
require recipes-platform/images/agl-image-minimal-crosssdk.inc
# Add wayland-scanner to SDK (SPEC-945)
@@ -50,10 +42,10 @@ TOOLCHAIN_TARGET_TASK += "waltham-dev"
TOOLCHAIN_HOST_TASK += " \
nativesdk-lua \
- "
+"
# Required dependencies for app and test builds
TOOLCHAIN_TARGET_TASK += " \
lua-dev \
lua-staticdev \
- "
+"
diff --git a/recipes-platform/images/agl-ivi-demo-platform-html5.bb b/recipes-platform/images/agl-ivi-demo-platform-html5.bb
index bef66eb3..805e239a 100644
--- a/recipes-platform/images/agl-ivi-demo-platform-html5.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform-html5.bb
@@ -1,14 +1,9 @@
-SUMMARY = "DEMO platform of AGL HTML5 profile"
-DESCRIPTION = "Contains the web runtime and sample web apps"
-
require agl-image-ivi.bb
-LICENSE = "MIT"
-
-IMAGE_FEATURES:append = " \
- "
+SUMMARY = "DEMO platform of AGL HTML5 profile"
+DESCRIPTION = "Contains the web runtime and sample web apps"
# add packages for demo platform (include demo apps) here
IMAGE_INSTALL:append = " \
packagegroup-agl-demo-platform-html5 \
- "
+"
diff --git a/recipes-platform/images/agl-ivi-demo-platform.bb b/recipes-platform/images/agl-ivi-demo-platform.bb
index 78a6b2c2..d3bda6ae 100644
--- a/recipes-platform/images/agl-ivi-demo-platform.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform.bb
@@ -1,13 +1,15 @@
+require agl-image-ivi.bb
+
DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
demos."
-require agl-image-ivi.bb
-
+FEATURE_PACKAGES_agl-demo-preload = "packagegroup-agl-demo-preload"
+FEATURE_PACKAGES_agl-demo-cluster-support = "packagegroup-agl-demo-cluster-support"
-LICENSE = "MIT"
+IMAGE_FEATURES += "${@bb.utils.filter("AGL_FEATURES", "agl-demo-preload agl-demo-cluster-support", d)}"
# add packages for demo platform (include demo apps) here
IMAGE_INSTALL:append = " \
packagegroup-agl-demo-platform \
- "
+"