summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb33
1 files changed, 18 insertions, 15 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index ac82d73c..d0c81c6a 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -1,34 +1,37 @@
-SUMMARY = "The software for DEMO platform of AGL HTML5 profile"
-DESCRIPTION = "Packages required to demo the HTML5 profile and sample web apps"
+SUMMARY = "The software for DEMO platform of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL Demo Platform"
LICENSE = "MIT"
inherit packagegroup
+PROVIDES = "${PACKAGES}"
PACKAGES = "\
packagegroup-agl-demo-platform-html5 \
+ packagegroup-agl-demo-platform-html5-devel \
"
ALLOW_EMPTY:${PN} = "1"
RDEPENDS:${PN} += "\
packagegroup-agl-image-ivi \
- packagegroup-agl-profile-graphical-html5 \
- packagegroup-agl-demo \
"
-AGL_APPS = " \
- html5-homescreen \
- html5-launcher \
- html5-hvac \
- html5-settings \
- html5-mixer \
- html5-mediaplayer \
- html5-dashboard \
- html5-background \
+RDEPENDS:${PN} += "\
+ packagegroup-hmi-framework \
"
+
RDEPENDS:${PN}:append = " \
- weston-ini-conf-landscape \
- ${AGL_APPS} \
+ weston-ini-conf \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+ "
+
+# NOTE: Currently no coverage versions for the application widgets,
+# they should be added here when available.
+# Also, the navigation and mixer debug widgets are currently
+# specified explicitly, as there's no simple way to derive their
+# names from the virtual/ RPROVIDES at present.
+RDEPENDS:${PN}-devel = " \
+ packagegroup-hmi-framework-devel \
"