summaryrefslogtreecommitdiffstats
path: root/recipes-platform/packagegroups
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-platform/packagegroups')
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb29
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-cluster-demo-qtcompositor.bb32
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb23
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb35
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb15
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb80
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb23
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo.bb54
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb27
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb6
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-graphics.bb5
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-identity.bb11
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia-hardware.bb21
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia.bb24
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb4
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb40
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-kuksa-val-databroker.bb21
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-kuksa-val-server.bb15
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-networking.bb21
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-source-han-sans-ttf-fonts.bb20
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-speech-services.bb11
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-telematics-demo-platform.bb18
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-ttf-fonts.bb21
-rw-r--r--recipes-platform/packagegroups/packagegroup-hmi-framework.bb23
-rw-r--r--recipes-platform/packagegroups/packagegroup-qt5-toolchain-target.bbappend1
-rw-r--r--recipes-platform/packagegroups/packagegroup-qt5-toolchain-target_agldemo.inc18
26 files changed, 354 insertions, 244 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
new file mode 100644
index 00000000..4cd03b66
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-platform.bb
@@ -0,0 +1,29 @@
+SUMMARY = "The software for demo platform of AGL cluster profile"
+DESCRIPTION = "A set of packages belong to AGL Cluster Demo Platform"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-cluster-demo-platform \
+ "
+
+ALLOW_EMPTY:${PN} = "1"
+
+RDEPENDS:${PN} += "\
+ packagegroup-agl-ttf-fonts \
+ packagegroup-agl-source-han-sans-ttf-fonts \
+ packagegroup-agl-networking \
+ "
+
+AGL_APPS = " \
+ cluster-dashboard \
+ cluster-receiver \
+ qt-cluster-receiver \
+ "
+
+RDEPENDS:${PN}:append = " \
+ can-utils \
+ ${AGL_APPS} \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-qtcompositor.bb b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-qtcompositor.bb
new file mode 100644
index 00000000..a5c8b78e
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-cluster-demo-qtcompositor.bb
@@ -0,0 +1,32 @@
+SUMMARY = "The software for AGL Cluster Demo Qtwayland Compositor"
+DESCRIPTION = "A set of packages belong to AGL Cluster Demo Qtwayland Compositor"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-cluster-demo-qtcompositor \
+ "
+
+ALLOW_EMPTY:${PN} = "1"
+
+RDEPENDS:${PN} += "\
+ packagegroup-agl-profile-cluster-qtcompositor \
+ packagegroup-agl-ttf-fonts \
+ packagegroup-agl-networking \
+ "
+
+AGL_SERVICE = " \
+ "
+
+AGL_APPS = " \
+ cluster-gauges-qtcompositor \
+ "
+
+RDEPENDS:${PN}:append = " \
+ linux-firmware-ralink \
+ can-utils \
+ ${AGL_SERVICE} \
+ ${AGL_APPS} \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
new file mode 100644
index 00000000..3fba1b8c
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
@@ -0,0 +1,23 @@
+SUMMARY = "The software for Flutter Demo platform of AGL IVI profile"
+DESCRIPTION = "A set of packages for AGL Flutter Demo Platform"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PROVIDES = "${PACKAGES}"
+PACKAGES = "\
+ packagegroup-agl-demo-platform-flutter \
+ "
+
+RDEPENDS:${PN} += "\
+ packagegroup-agl-demo \
+ "
+
+RDEPENDS:${PN}:append = " \
+ agl-compositor \
+ flutter-auto \
+ agl-flutter-env \
+ applaunchd-template-agl-app-flutter \
+ psplash-portrait-config \
+ "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 6ec717bd..c5a9209b 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -1,32 +1,43 @@
-SUMMARY = "The software for DEMO platform of AGL HTML5 profile"
-DESCRIPTION = "Packages required to demo the HTML5 profile and sample web apps"
+SUMMARY = "The software for DEMO platform of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL Demo Platform"
LICENSE = "MIT"
inherit packagegroup
+PROVIDES = "${PACKAGES}"
PACKAGES = "\
packagegroup-agl-demo-platform-html5 \
"
-ALLOW_EMPTY_${PN} = "1"
-
-RDEPENDS_${PN} += "\
- packagegroup-agl-image-ivi \
- packagegroup-agl-profile-graphical-html5 \
+RDEPENDS:${PN} += "\
packagegroup-agl-demo \
"
+# TODO(jdapena): replace this with HTML5 apps.
AGL_APPS = " \
- html5-homescreen \
+ html5-dashboard \
html5-launcher \
+ html5-homescreen \
html5-hvac \
- html5-settings \
- html5-mixer \
html5-mediaplayer \
- html5-dashboard \
+ html5-mixer \
+ html5-settings \
+ html5-aquarium \
+ html5-youtube \
+ html5-jitsi \
+ html5-examples \
"
-RDEPENDS_${PN}_append = " \
+RDEPENDS:${PN}:append = " \
+ wam \
+ weston-ini-conf-landscape-no-activate \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+ qtquickcontrols2-agl \
+ qtquickcontrols2-agl-style \
${AGL_APPS} \
"
+
+# nss-agl-driver-db is required to connect to kuksa
+RDEPENDS:${PN}:append = " nss-agl-driver-db "
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb
deleted file mode 100644
index 739f859b..00000000
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "The software for DEMO platform of AGL IVI profile"
-DESCRIPTION = "A set of packages belong to AGL Demo Platform includes utilities for testing distribution as Quality Assurance"
-
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-agl-demo-platform-qa \
- "
-
-ALLOW_EMPTY_${PN} = "1"
-
-RDEPENDS_${PN} += "\
- "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 28777e2b..28f79cf2 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -5,86 +5,20 @@ LICENSE = "MIT"
inherit packagegroup
+PROVIDES = "${PACKAGES}"
PACKAGES = "\
packagegroup-agl-demo-platform \
"
-ALLOW_EMPTY_${PN} = "1"
-
-RDEPENDS_${PN} += "\
- packagegroup-agl-image-ivi \
- "
-
-RDEPENDS_${PN} += "\
- packagegroup-agl-profile-graphical-qt5 \
+RDEPENDS:${PN} += "\
packagegroup-agl-demo \
"
-
-AGL_APPS = " \
- dashboard \
- hvac \
- mediaplayer \
- virtual/navigation \
- phone \
- poiapp \
- radio \
- settings \
- messaging \
- ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
- low-can-demo \
- virtual/mixer \
- ${@bb.utils.contains('IMAGE_FEATURES', 'agl-voiceagent-alexa', 'alexa-viewer' , '', d)} \
- "
-
-QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
-QTAGLEXTRAS_append = " libqtappfw"
-
-# add support for websocket in Qt and QML
-QTAGLEXTRAS_append = " qtwebsockets qtwebsockets-qmlplugins"
-PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
-
-#QTAGLEXTRAS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'qtwebengine', '', d)}"
-#QTAGLEXTRAS_append = " qtsmarthome cinematicexperience qt5everywheredemo qt5-demo-extrafiles"
-#IMAGE_INSTALL_append = " qtwebengine-examples"
-
-# packages from hmi-framework aka homescreen-2017
-HOMESCREEN = "packagegroup-hmi-framework"
-
-# Cluster demo support.
-# ATM no cluster map viewer is supported with the older navigation application.
-MAPVIEWER = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "ondemandnavi", "tbtnavi", "",d)}"
-CLUSTER_SUPPORT_PACKAGES = " \
- ${MAPVIEWER} \
- cluster-demo-network-config \
- cluster-lin-bridging-config \
- cluster-demo-simulator \
-"
-CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
-
-DEMO_UNIT_CONF ?= ""
-# Hook for demo platform configuration
-# ATM used for:
-# 1) Adding udev configuration and scripts for supporting USB attached
-# I2C devices for RTC and HVAC LED support.
-DEMO_UNIT_CONF += " demo-i2c-udev-conf "
-
-# Preload poi API key for demo if requested, and potentially maps for older
-# navigation application if it is configured.
-DEMO_MAPS_LOCALE ?= "uk"
-DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
-
-# Preload only if agl-demo-preload is set
-DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
-
-
-RDEPENDS_${PN}_append = " \
+RDEPENDS:${PN}:append = " \
+ weston-ini-conf-no-activate \
+ homescreen \
+ launcher \
qtquickcontrols2-agl \
qtquickcontrols2-agl-style \
- ${AGL_APPS} \
- ${QTAGLEXTRAS} \
- ${CLUSTER_SUPPORT} \
- ${DEMO_PRELOAD} \
- ${HOMESCREEN} \
+ psplash-portrait-config \
"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb
new file mode 100644
index 00000000..808c93c6
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Extra software and configuration for tradeshow demo with AGL IVI profile demo platform"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PROVIDES = "${PACKAGES}"
+PACKAGES = " \
+ packagegroup-agl-demo-preload \
+"
+
+# NOTES:
+# - demo-i2c-udev-conf:
+# Adds udev configuration and scripts for supporting USB attached
+# I2C devices for RTC and HVAC LED support.
+# - simple-can-simulator:
+# CAN message simulator for vehicle and engine speed message
+# generation, with some support for the cruise control events from
+# the steering wheel used in the demo setup.
+#
+RDEPENDS:${PN} = "\
+ demo-i2c-udev-conf \
+ simple-can-simulator \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo.bb b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
index 86da3403..90283e06 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
@@ -9,50 +9,12 @@ PACKAGES = "\
packagegroup-agl-demo \
"
-ALLOW_EMPTY_${PN} = "1"
-
-# MOST out-of-tree kernel drivers
-#################################
-MOST_DRIVERS ??= " \
- most \
- "
-# These boards use different kernels - needs to be checked
-MOST_DRIVERS_dragonboard-410c ?= ""
-MOST_DRIVERS_cyclone5 ?= ""
-
-
-# HVAC dependencies
-###################
-LIN_DRIVERS ??= " sllin sllin-virtual"
-# These boards use different kernels - needs to be checked
-LIN_DRIVERS_dra7xx-evm ?= "sllin-virtual"
-LIN_DRIVERS_dragonboard-410c ?= "sllin-virtual"
-
-# UNICENS service
-UNICENS ?= " \
- unicens-config \
- agl-service-unicens \
- agl-service-unicens-controller \
- "
-
# Hook for demo platform configuration
# ATM, only used to disable btwilink module on [MH]3ULCB + Kingfisher by default,
# setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
DEMO_ENABLE_BTWILINK ?= ""
DEMO_PLATFORM_CONF = ""
-DEMO_PLATFORM_CONF_append_ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
-
-SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
- 'packagegroup-agl-smartdevicelink', '', d)}"
-
-# removed: now all enablers are in meta-agl-devel/meta-audio-soundmanager-framework
-# old audio package
-# AUDIO-OLD = "audiomanager"
-
-RDEPENDS_${PN} += "\
- udisks2 \
- ${SMARTDEVICELINK} \
- "
+DEMO_PLATFORM_CONF:append:ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
# fonts
TTF_FONTS = " \
@@ -64,22 +26,14 @@ TTF_FONTS = " \
source-han-sans-cn-fonts \
source-han-sans-jp-fonts \
source-han-sans-tw-fonts \
+ source-han-sans-kr-fonts \
"
-
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
+ udisks2 \
linux-firmware-ath9k \
linux-firmware-ralink \
- can-utils \
iproute2 \
- python-curses \
- dhcp-client \
- ${UNICENS} \
- ${MOST_DRIVERS} \
- ${LIN_DRIVERS} \
${DEMO_PLATFORM_CONF} \
${TTF_FONTS} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'webruntime', 'virtual/webruntime', '', d)} \
"
-
-
diff --git a/recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb b/recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb
deleted file mode 100644
index acaa405a..00000000
--- a/recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-SUMMARY = "The middlewares for AGL IVI profile"
-DESCRIPTION = "The set of packages required for AGL Distribution"
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-agl-image-ivi \
- "
-
-ALLOW_EMPTY_${PN} = "1"
-
-RDEPENDS_${PN} += "\
- packagegroup-agl-image-minimal \
-"
-
-RDEPENDS_${PN} += "\
- packagegroup-agl-ivi-connectivity \
- packagegroup-agl-ivi-graphics \
- packagegroup-agl-ivi-multimedia \
- packagegroup-agl-ivi-navigation \
- packagegroup-agl-ivi-services \
- "
-
-RDEPENDS_${PN} += "\
- agl-login-manager \
- "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb
index 17d0d4b6..aa87db52 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-connectivity.bb
@@ -8,13 +8,11 @@ PACKAGES = "\
packagegroup-agl-ivi-connectivity \
"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
bluez5-obex \
${@bb.utils.contains("DISTRO_FEATURES", "3g", "libqmi", "", d)} \
rtl-sdr \
- neard \
- neardal-tools \
ofono \
"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-graphics.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-graphics.bb
index 8831e10a..c5807ed2 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-ivi-graphics.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-graphics.bb
@@ -8,8 +8,7 @@ PACKAGES = "\
packagegroup-agl-ivi-graphics \
"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
-RDEPENDS_${PN} += "\
- opencv \
+RDEPENDS:${PN} += "\
"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-identity.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-identity.bb
new file mode 100644
index 00000000..3cd16378
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-identity.bb
@@ -0,0 +1,11 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required for identity services"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+ALLOW_EMPTY:${PN} = "1"
+
+RDEPENDS:${PN} += "\
+"
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia-hardware.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia-hardware.bb
new file mode 100644
index 00000000..e52e8ef5
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia-hardware.bb
@@ -0,0 +1,21 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "Hardware-specific packages required by Multimedia Subsystem"
+LICENSE = "MIT"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-multimedia-hardware \
+ "
+
+ALLOW_EMPTY:${PN} = "1"
+
+RDEPENDS:${PN} = ""
+
+RDEPENDS:${PN}:append:rcar-gen3 = "\
+ ${@bb.utils.contains('MACHINE_FEATURES', 'multimedia', 'packagegroup-multimedia-kernel-modules', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'multimedia', 'packagegroup-multimedia-libs', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'multimedia', 'packagegroup-gstreamer1.0-plugins', '', d)} \
+ "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia.bb
index 34622efd..78c96faf 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia.bb
@@ -8,20 +8,18 @@ PACKAGES = "\
packagegroup-agl-ivi-multimedia \
"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
-RDEPENDS_${PN} += "\
- gstreamer1.0-plugins-base-meta \
- gstreamer1.0-plugins-good-meta \
- lightmediascanner-meta \
- "
-
-# for now: enable here for the AGL IVI demo (image-ivi and demo-platform)
-# tbd: change based on usage in profiles
-PIPEWIRE = "\
- ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)}\
+PIPEWIRE_PACKAGES = " \
+ packagegroup-pipewire \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-pipewire-tools alsa-utils', '', d)} \
+ wireplumber-config-agl \
+ wireplumber-policy-config-agl \
"
-RDEPENDS_${PN} += "\
- ${PIPEWIRE} \
+RDEPENDS:${PN} += "\
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', '${PIPEWIRE_PACKAGES}', '', d)} \
+ gstreamer1.0-plugins-base-meta \
+ gstreamer1.0-plugins-good-meta \
+ ${@bb.utils.contains('AGL_FEATURES', 'agl-kvm-host-audio', '', 'mpd', d)} \
"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb
index 90daf923..f6c5e155 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-navigation.bb
@@ -10,8 +10,8 @@ PACKAGES = "\
packagegroup-agl-ivi-navigation \
"
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
gpsd \
- virtual/gpsd-conf \
+ gpsd-machine-conf \
geoclue \
"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
index 40359ed3..c3a53d50 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
@@ -1,30 +1,26 @@
-DESCRIPTION = "The minimal set of packages for AGL IVI Connectivity Subsystem"
+DESCRIPTION = "The minimal set of services to support AGL IVI demo"
LICENSE = "MIT"
inherit packagegroup
PACKAGES = "\
packagegroup-agl-ivi-services \
- "
+ packagegroup-agl-ivi-services-platform \
+ packagegroup-agl-ivi-services-applaunchd \
+"
-ALLOW_EMPTY_${PN} = "1"
+RDEPENDS:${PN}-applaunchd += " \
+ applaunchd \
+ applaunchd-template-agl-app \
+"
-RDEPENDS_${PN} += "\
-agl-service-bluetooth \
-agl-service-bluetooth-map \
-agl-service-bluetooth-pbap \
-agl-service-can-high-level-viwi \
-agl-service-can-low-level \
-agl-service-geoclue \
-agl-service-geofence \
-agl-service-gps \
-agl-service-identity-agent \
-agl-service-iiodevices \
-agl-service-mediascanner \
-agl-service-navigation \
-agl-service-nfc \
-agl-service-signal-composer \
-agl-service-steering-wheel \
-agl-service-unicens \
-agl-service-weather \
- "
+RDEPENDS:${PN}-platform += " \
+ agl-service-hvac \
+ agl-service-audiomixer \
+ agl-service-radio \
+"
+
+RDEPENDS:${PN} += " \
+ packagegroup-agl-ivi-services-applaunchd \
+ packagegroup-agl-ivi-services-platform \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-kuksa-val-databroker.bb b/recipes-platform/packagegroups/packagegroup-agl-kuksa-val-databroker.bb
new file mode 100644
index 00000000..a9382e5b
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-kuksa-val-databroker.bb
@@ -0,0 +1,21 @@
+SUMMARY = "KUKSA.val databroker packages"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-kuksa-val-databroker \
+ packagegroup-agl-kuksa-val-databroker-devel \
+"
+
+RDEPENDS:packagegroup-agl-kuksa-val-databroker = "\
+ kuksa-databroker \
+ kuksa-databroker-agl \
+ kuksa-certificates-agl \
+ kuksa-dbc-feeder \
+ agl-vss-helper \
+"
+
+RDEPENDS:packagegroup-agl-kuksa-val-databroker-devel = "\
+ kuksa-databroker-cli \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-kuksa-val-server.bb b/recipes-platform/packagegroups/packagegroup-agl-kuksa-val-server.bb
new file mode 100644
index 00000000..82a5b020
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-kuksa-val-server.bb
@@ -0,0 +1,15 @@
+SUMMARY = "KUKSA.val server packages"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-kuksa-val-server \
+"
+
+RDEPENDS:packagegroup-agl-kuksa-val-server = "\
+ kuksa-val \
+ kuksa-val-agl \
+ kuksa-certificates-agl \
+ kuksa-dbc-feeder \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-networking.bb b/recipes-platform/packagegroups/packagegroup-agl-networking.bb
new file mode 100644
index 00000000..74f7757a
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-networking.bb
@@ -0,0 +1,21 @@
+SUMMARY = "The networking for AGL"
+DESCRIPTION = "A set of packages for AGL cluster's networking"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-networking \
+ "
+
+ALLOW_EMPTY:${PN} = "1"
+
+
+# fonts
+RDEPENDS:${PN}:append = " \
+ connman \
+ connman-client \
+ connman-tools \
+ iproute2 \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-source-han-sans-ttf-fonts.bb b/recipes-platform/packagegroups/packagegroup-agl-source-han-sans-ttf-fonts.bb
new file mode 100644
index 00000000..0afb9505
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-source-han-sans-ttf-fonts.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The Source Han Sans ttf fonts for AGL"
+DESCRIPTION = "A set of packages for source Han Sans ttf fonts"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-source-han-sans-ttf-fonts \
+ "
+
+ALLOW_EMPTY:${PN} = "1"
+
+
+# fonts
+RDEPENDS:${PN}:append = " \
+ source-han-sans-cn-fonts \
+ source-han-sans-jp-fonts \
+ source-han-sans-tw-fonts \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-speech-services.bb b/recipes-platform/packagegroups/packagegroup-agl-speech-services.bb
new file mode 100644
index 00000000..ceffd093
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-speech-services.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "The set of packages for AGL Speech Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-speech-services \
+ "
+
+RDEPENDS:${PN} += "\
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-telematics-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-telematics-demo-platform.bb
new file mode 100644
index 00000000..96ad7138
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-telematics-demo-platform.bb
@@ -0,0 +1,18 @@
+SUMMARY = "The software for AGL telematics profile demo platform"
+DESCRIPTION = "A set of packages belonging to the AGL telematics demo platform"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-telematics-demo-platform \
+ "
+
+RDEPENDS:${PN}:append = " \
+ gpsd \
+ sw-gpsd-udev-conf \
+ usb-can-udev-conf \
+ simple-can-simulator \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'ofono-tests gps-utils' , '', d)} \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-ttf-fonts.bb b/recipes-platform/packagegroups/packagegroup-agl-ttf-fonts.bb
new file mode 100644
index 00000000..4bc11de6
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-ttf-fonts.bb
@@ -0,0 +1,21 @@
+SUMMARY = "The ttf fonts for AGL"
+DESCRIPTION = "A set of packages for fonts"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ttf-fonts \
+ "
+
+ALLOW_EMPTY:${PN} = "1"
+
+
+# fonts
+RDEPENDS:${PN}:append = " \
+ ttf-bitstream-vera \
+ ttf-dejavu-sans \
+ ttf-dejavu-sans-mono \
+ ttf-dejavu-serif \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-hmi-framework.bb b/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
deleted file mode 100644
index cf704e63..00000000
--- a/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "The software for the AGL hmi framework 2017"
-DESCRIPTION = "A set of packages belong to the hmi framework 2017"
-
-LICENSE = "MIT"
-
-# need to bump manually due to:
-# - nothing provides libqthomescreenwrapper0 needed by packagegroup-hmi-framework-1.0-r0.noarch
-PR = "2"
-
-inherit packagegroup
-
-RDEPENDS_${PN} += " \
- agl-service-windowmanager \
- agl-service-homescreen \
- homescreen \
- libwindowmanager \
- qlibwindowmanager \
- libhomescreen \
- qlibhomescreen \
- runxdg \
- hmi-debug \
- launcher \
-"
diff --git a/recipes-platform/packagegroups/packagegroup-qt5-toolchain-target.bbappend b/recipes-platform/packagegroups/packagegroup-qt5-toolchain-target.bbappend
new file mode 100644
index 00000000..3583515f
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-qt5-toolchain-target.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'packagegroup-qt5-toolchain-target_agldemo.inc', '', d)}
diff --git a/recipes-platform/packagegroups/packagegroup-qt5-toolchain-target_agldemo.inc b/recipes-platform/packagegroups/packagegroup-qt5-toolchain-target_agldemo.inc
new file mode 100644
index 00000000..a677f40d
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-qt5-toolchain-target_agldemo.inc
@@ -0,0 +1,18 @@
+# add missing dependencies for SDK
+
+RDEPENDS:${PN} += " \
+ qttools-plugins \
+ qtquickcontrols-dev \
+ qtquickcontrols-qmlplugins \
+ qtquickcontrols2-dev \
+ qtquickcontrols2-mkspecs \
+ qtquickcontrols2-qmlplugins \
+"
+
+# remove dependency on qtwebkit (still added to SDK by packagegroup-qt5-toolchain-target)
+# see SPEC-1159
+RDEPENDS:${PN}:remove = " \
+ qtwebkit-dev \
+ qtwebkit-mkspecs \
+ qtwebkit-qmlplugins \
+"