summaryrefslogtreecommitdiffstats
path: root/recipes-qt/packagegroups
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/packagegroups')
-rw-r--r--recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb32
-rw-r--r--recipes-qt/packagegroups/packagegroup-agl-demo-qt-examples.bb26
-rw-r--r--recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bbappend23
3 files changed, 0 insertions, 81 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
deleted file mode 100644
index a22401ff..00000000
--- a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-SUMMARY = "Qt5 for native GUI framework of AGL IVI profile"
-DESCRIPTION = "A set of Qt5 packages which required by Native App Fw Subsystem"
-
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-agl-appfw-native-qt5 \
- "
-
-ALLOW_EMPTY_${PN} = "1"
-
-RDEPENDS_${PN} += "\
- qtbase \
- qtbase-dev \
- qtbase-plugins \
- qtbase-staticdev \
- qtbase-tools \
- qtdeclarative \
- qtdeclarative-qmlplugins \
- qtdeclarative-tools \
- qtcharts \
- qtwayland \
- qtwayland-plugins \
- qtwayland-tools \
- qtgraphicaleffects-qmlplugins \
- qtvirtualkeyboard \
- "
-RDEPENDS_${PN}_checkforkrogoth += "\
- qtwayland-examples \
- "
diff --git a/recipes-qt/packagegroups/packagegroup-agl-demo-qt-examples.bb b/recipes-qt/packagegroups/packagegroup-agl-demo-qt-examples.bb
deleted file mode 100644
index adebabe7..00000000
--- a/recipes-qt/packagegroups/packagegroup-agl-demo-qt-examples.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "The examples to test Qt5 on AGL Demo Platform"
-DESCRIPTION = "A set of packages which contains Qt5 examples"
-
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-agl-demo-qt-examples \
- "
-
-ALLOW_EMPTY_${PN} = "1"
-
-RDEPENDS_${PN} += "\
- qt3d-examples \
- qtbase-examples \
- qtconnectivity-examples \
- qtdeclarative-examples \
- qtlocation-examples \
- qtmultimedia-examples \
- qtsensors-examples \
- qtsystems-examples \
- qttools-examples \
- qtwayland-examples \
- qtxmlpatterns-examples \
- "
diff --git a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bbappend b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bbappend
deleted file mode 100644
index 300227e1..00000000
--- a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
-# add missing dependencies for SDK
-
-RDEPENDS_${PN} += " \
- qttools-plugins \
- qtquickcontrols-dev \
- qtquickcontrols-qmlplugins \
- qtquickcontrols2-dev \
- qtquickcontrols2-mkspecs \
- qtquickcontrols2-qmlplugins \
-"
-
-# remove dependency on qtwebkit (still added to SDK by packagegroup-qt5-toolchain-target)
-# see SPEC-1159
-RDEPENDS_${PN}_remove = " \
- qtwebkit-dev \
- qtwebkit-mkspecs \
- qtwebkit-qmlplugins \
-"
-
-# add QtAGLExtras
-RDEPENDS_${PN} += " \
- ${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras-dev qtaglextras-mkspecs", "",d)} \
-"