aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2019-06-29 07:29:57 +0200
committerJacobo Aragunde Pérez <jaragunde@igalia.com>2019-06-29 07:32:54 +0200
commitdca1794cc1928bb00489fb6f2c1c2310628e8a41 (patch)
tree84454d4f9dc97fc9589e4d16f2f6bd0015d17567
parentfcfbd7497c73413bd35d1a641686f2c095626daa (diff)
Backport upstream patch: https://chromium-review.googlesource.com/c/chromium/third_party/ffmpeg/+/1390286 Fix this warning when linking libcbe.so: obj/third_party/ffmpeg/ffmpeg_internal/ autorename_libavcodec_aarch64_h264idct_neon.o: relocation R_AARCH64_ADR_PREL_PG_HI21 against symbol `ff_h264_idct8_add_neon' which may bind externally can not be used when making a shared object; recompile with -fPIC Bug-AGL: SPEC-2506 Change-Id: Ib18f93be86dfdfa5e4a896f3a851626beb9282b8 Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
-rw-r--r--meta-html5-framework/recipes-wam/chromium/chromium68/0001-libavcodec-Remove-dynamic-relocs-from-h264idct_neon..patch107
-rw-r--r--meta-html5-framework/recipes-wam/chromium/chromium68_git.bb1
2 files changed, 108 insertions, 0 deletions
diff --git a/meta-html5-framework/recipes-wam/chromium/chromium68/0001-libavcodec-Remove-dynamic-relocs-from-h264idct_neon..patch b/meta-html5-framework/recipes-wam/chromium/chromium68/0001-libavcodec-Remove-dynamic-relocs-from-h264idct_neon..patch
new file mode 100644
index 00000000..a522c771
--- /dev/null
+++ b/meta-html5-framework/recipes-wam/chromium/chromium68/0001-libavcodec-Remove-dynamic-relocs-from-h264idct_neon..patch
@@ -0,0 +1,107 @@
+From 67e9e0337185f05a0d8d362473e63d8a9dfdebed Mon Sep 17 00:00:00 2001
+From: Manoj Gupta <manojgupta@google.com>
+Date: Thu, 27 Dec 2018 11:06:26 -0800
+Subject: [PATCH] libavcodec: Remove dynamic relocs from h264idct_neon.S
+
+Some of the assembly functions e.g. ff_h264_idct_dc_add_neon
+has code like:
+ movrel x14, X(ff_h264_idct_add_neon)
+
+Linker cannot resolve them fully at link time and emits GOT
+relocations.
+Use explicit labels instead so that no dynamic relocations are
+needed at all.
+
+BUG=chromium:917919
+TEST=lld complains are fixed.
+
+Change-Id: Ie533a10aab1fe3834300599ce650d3673a674f4e
+Reviewed-on: https://chromium-review.googlesource.com/c/1390286
+Reviewed-by: Frank Liberato <liberato@chromium.org>
+---
+ libavcodec/aarch64/h264idct_neon.S | 20 ++++++++++++--------
+ 1 file changed, 12 insertions(+), 8 deletions(-)
+
+diff --git a/src/third_party/ffmpeg/libavcodec/aarch64/h264idct_neon.S b/src/third_party/ffmpeg/libavcodec/aarch64/h264idct_neon.S
+index 825ec49f8c6d..7de44205d39a 100644
+--- a/src/third_party/ffmpeg/libavcodec/aarch64/h264idct_neon.S
++++ b/src/third_party/ffmpeg/libavcodec/aarch64/h264idct_neon.S
+@@ -23,6 +23,7 @@
+ #include "neon.S"
+
+ function ff_h264_idct_add_neon, export=1
++.L_ff_h264_idct_add_neon:
+ ld1 {v0.4H, v1.4H, v2.4H, v3.4H}, [x1]
+ sxtw x2, w2
+ movi v30.8H, #0
+@@ -77,6 +78,7 @@ function ff_h264_idct_add_neon, export=1
+ endfunc
+
+ function ff_h264_idct_dc_add_neon, export=1
++.L_ff_h264_idct_dc_add_neon:
+ sxtw x2, w2
+ mov w3, #0
+ ld1r {v2.8H}, [x1]
+@@ -106,8 +108,8 @@ function ff_h264_idct_add16_neon, export=1
+ mov w9, w3 // stride
+ movrel x7, scan8
+ mov x10, #16
+- movrel x13, X(ff_h264_idct_dc_add_neon)
+- movrel x14, X(ff_h264_idct_add_neon)
++ movrel x13, .L_ff_h264_idct_dc_add_neon
++ movrel x14, .L_ff_h264_idct_add_neon
+ 1: mov w2, w9
+ ldrb w3, [x7], #1
+ ldrsw x0, [x5], #4
+@@ -133,8 +135,8 @@ function ff_h264_idct_add16intra_neon, export=1
+ mov w9, w3 // stride
+ movrel x7, scan8
+ mov x10, #16
+- movrel x13, X(ff_h264_idct_dc_add_neon)
+- movrel x14, X(ff_h264_idct_add_neon)
++ movrel x13, .L_ff_h264_idct_dc_add_neon
++ movrel x14, .L_ff_h264_idct_add_neon
+ 1: mov w2, w9
+ ldrb w3, [x7], #1
+ ldrsw x0, [x5], #4
+@@ -160,8 +162,8 @@ function ff_h264_idct_add8_neon, export=1
+ add x5, x1, #16*4 // block_offset
+ add x9, x2, #16*32 // block
+ mov w19, w3 // stride
+- movrel x13, X(ff_h264_idct_dc_add_neon)
+- movrel x14, X(ff_h264_idct_add_neon)
++ movrel x13, .L_ff_h264_idct_dc_add_neon
++ movrel x14, .L_ff_h264_idct_add_neon
+ movrel x7, scan8, 16
+ mov x10, #0
+ mov x11, #16
+@@ -263,6 +265,7 @@ endfunc
+ .endm
+
+ function ff_h264_idct8_add_neon, export=1
++.L_ff_h264_idct8_add_neon:
+ movi v19.8H, #0
+ sxtw x2, w2
+ ld1 {v24.8H, v25.8H}, [x1]
+@@ -326,6 +329,7 @@ function ff_h264_idct8_add_neon, export=1
+ endfunc
+
+ function ff_h264_idct8_dc_add_neon, export=1
++.L_ff_h264_idct8_dc_add_neon:
+ mov w3, #0
+ sxtw x2, w2
+ ld1r {v31.8H}, [x1]
+@@ -375,8 +379,8 @@ function ff_h264_idct8_add4_neon, export=1
+ mov w2, w3
+ movrel x7, scan8
+ mov w10, #16
+- movrel x13, X(ff_h264_idct8_dc_add_neon)
+- movrel x14, X(ff_h264_idct8_add_neon)
++ movrel x13, .L_ff_h264_idct8_dc_add_neon
++ movrel x14, .L_ff_h264_idct8_add_neon
+ 1: ldrb w9, [x7], #4
+ ldrsw x0, [x5], #16
+ ldrb w9, [x4, w9, UXTW]
+--
+2.21.0
+
diff --git a/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb b/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
index 3c93f7b0..14590f47 100644
--- a/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
+++ b/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
@@ -21,6 +21,7 @@ PROVIDES = "${BROWSER_APPLICATION}"
SRC_URI = "\
git://github.com/webosose/${PN};branch=@39.agl.guppy;protocol=https;rev=${SRCREV_chromium68} \
git://github.com/webosose/v8;destsuffix=git/src/v8;rev=${SRCREV_v8} \
+ file://0001-libavcodec-Remove-dynamic-relocs-from-h264idct_neon..patch \
"
SRCREV_chromium68 = "259a8b56bc833956f3acd318b7f19b028277beda"
SRCREV_v8 = "1e3af71f1ff3735e8a5b639c48dfca63a7b8a647"