aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-20 17:26:59 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-20 17:29:36 -0500
commitc18547e424f1ab771e071947bf0df9854561c166 (patch)
tree5467a43de0d9a31170f27a96101cc7fdc7746e17
parent4066d09cf1fd687073a9fa4d1698ab07cbbfa306 (diff)
meta-aac: Rework agl-voiceagent-alexa packaginghalibut_8.0.6halibut_8.0.5halibut/8.0.6halibut/8.0.58.0.68.0.5halibut
Rather than appending the agl-voiceagent-alexa packages onto the existing packagegroup-agl-core-services, instead define a new specific packagegroup-agl-voiceagent-alexa, and an associated image feature that is used to include it into an image with IMAGE_FEATURES. This seems better for the longer-term goal of a binary package feed, and IMAGE_FEATURES can be used by other recipes in a similar manner as DISTRO_FEATURES, but with a lot less build dependency impact if changed. This will be used in a parallel change to meta-agl-demo to pull in the new alexa-viewer application when using the Alexa voiceagent. Bug-AGL: SPEC-3110 Change-Id: I15fb07560fef703e3471bce9e50596cb4a6667b4 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-speech-framework/conf/include/agl-voiceagent-alexa.inc4
-rw-r--r--meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-core-services.bbappend4
-rw-r--r--meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb15
3 files changed, 19 insertions, 4 deletions
diff --git a/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc b/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
index 7b478474..10df0926 100644
--- a/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
+++ b/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
@@ -4,3 +4,7 @@
BBMASK += "meta-aac/recipes-support/curl/curl_%.bbappend"
PREFERRED_RPROVIDER_virtual/voice-high-config = "alexa-voice-high-config"
+
+FEATURE_PACKAGES_agl-voiceagent-alexa = "packagegroup-agl-voiceagent-alexa"
+
+IMAGE_FEATURES += "agl-voiceagent-alexa"
diff --git a/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-core-services.bbappend b/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-core-services.bbappend
deleted file mode 100644
index 43836942..00000000
--- a/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-core-services.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-RDEPENDS_${PN} += " \
- alexa-voiceagent-service \
- ${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", "virtual/alexa-voiceagent-config", "",d)} \
-"
diff --git a/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb b/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb
new file mode 100644
index 00000000..5f38e7ef
--- /dev/null
+++ b/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb
@@ -0,0 +1,15 @@
+SUMMARY = "The software for the AGL Alexa voiceagent feature"
+DESCRIPTION = "The software for the AGL Alexa voiceagent feature"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-voiceagent-alexa \
+"
+
+RDEPENDS_${PN} += " \
+ alexa-voiceagent-service \
+ ${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", "virtual/alexa-voiceagent-config", "",d)} \
+"