summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2016-10-18 14:07:56 +0900
committertte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2016-10-18 14:08:43 +0900
commitf25d5b743034c65add42639148ff16563a62b044 (patch)
tree883220760f2c2f11a4ea9d40fe58472eb531d5e3
parent5fb924b7d0136dd4bbafa7f309ba45b09d91f87f (diff)
Add iptables porter(m2) kernel configure by zheng@toyotamorty
Change-Id: I810ba89ef47981168c2ee6dbc9967c30eefed175 Signed-off-by: tte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>
-rw-r--r--meta-renesas-kernel/conf/layer.conf10
-rw-r--r--meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend75
-rw-r--r--templates/feature/agl-renesas-kernel/50_bblayers.conf.inc4
3 files changed, 89 insertions, 0 deletions
diff --git a/meta-renesas-kernel/conf/layer.conf b/meta-renesas-kernel/conf/layer.conf
new file mode 100644
index 00000000..fa648fb3
--- /dev/null
+++ b/meta-renesas-kernel/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH =. "${LAYERDIR}:"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "renesas-kernel"
+BBFILE_PATTERN_renesas-kernel = "^${LAYERDIR}/"
+BBFILE_PRIORITY_renesas-kernel = "7"
diff --git a/meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend
new file mode 100644
index 00000000..518482f8
--- /dev/null
+++ b/meta-renesas-kernel/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -0,0 +1,75 @@
+do_configure_append_porter() {
+ # Enable CONFIG_NETFILTER
+ # kernel_configure_variable NETFILTER y
+ # kernel_configure_variable NETFILTER_ADVANCED y
+ #
+ # Core Netfilter Configuration
+ #
+ # kernel_configure_variable NF_CONNTRACK y
+ kernel_configure_variable NF_CONNTRACK_PROCFS y
+ kernel_configure_variable NF_CT_PROTO_UDPLITE y
+ kernel_configure_variable NF_CONNTRACK_BROADCAST y
+ kernel_configure_variable NF_CONNTRACK_SNMP y
+ kernel_configure_variable NF_NAT y
+ kernel_configure_variable NF_NAT_NEEDED y
+ kernel_configure_variable NF_NAT_PROTO_UDPLITE y
+ # kernel_configure_variable NETFILTER_XTABLES y
+ #
+ # Xtables combined modules
+ #
+ kernel_configure_variable NETFILTER_XT_MARK y
+ #
+ # Xtables targets
+ #
+ kernel_configure_variable NETFILTER_XT_TARGET_CT y
+ kernel_configure_variable NETFILTER_XT_TARGET_DSCP y
+ kernel_configure_variable NETFILTER_XT_TARGET_LOG y
+ kernel_configure_variable NETFILTER_XT_TARGET_MARK y
+ kernel_configure_variable NETFILTER_XT_TARGET_NETMAP y
+ kernel_configure_variable NETFILTER_XT_TARGET_NOTRACK y
+ kernel_configure_variable NETFILTER_XT_TARGET_REDIRECT y
+ kernel_configure_variable NETFILTER_XT_TARGET_TCPMSS y
+ kernel_configure_variable NETFILTER_XT_TARGET_TCPOPTSTRIP y
+ #
+ # Xtables matches
+ #
+ kernel_configure_variable NETFILTER_XT_MATCH_HASHLIMIT y
+ kernel_configure_variable NETFILTER_XT_MATCH_LENGTH y
+ kernel_configure_variable NETFILTER_XT_MATCH_LIMIT y
+ kernel_configure_variable NETFILTER_XT_MATCH_POLICY y
+ kernel_configure_variable NETFILTER_XT_MATCH_STATE y
+ kernel_configure_variable NETFILTER_XT_MATCH_TCPMSS y
+ kernel_configure_variable NETFILTER_XT_MATCH_TIME y
+ #
+ # IP: Netfilter Configuration
+ #
+ # kernel_configure_variable NF_DEFRAG_IPV4 y
+ # kernel_configure_variable NF_CONNTRACK_IPV4 y
+ kernel_configure_variable NF_CONNTRACK_PROC_COMPAT y
+ # kernel_configure_variable IP_NF_IPTABLES y
+ kernel_configure_variable IP_NF_FILTER y
+ kernel_configure_variable IP_NF_TARGET_REJECT y
+ kernel_configure_variable IP_NF_TARGET_ULOG y
+ # kernel_configure_variable NF_NAT_IPV4 y
+ # kernel_configure_variable IP_NF_TARGET_MASQUERADE y
+ kernel_configure_variable IP_NF_TARGET_NETMAP y
+ kernel_configure_variable IP_NF_TARGET_REDIRECT y
+ kernel_configure_variable NF_NAT_SNMP_BASIC y
+ kernel_configure_variable IP_NF_MANGLE y
+ kernel_configure_variable IP_NF_TARGET_ECN y
+ kernel_configure_variable IP_NF_RAW y
+ #
+ # IPv6: Netfilter Configuration
+ #
+ # kernel_configure_variable NF_DEFRAG_IPV6 y
+ kernel_configure_variable NF_CONNTRACK_IPV6 y
+ # kernel_configure_variable IP6_NF_IPTABLES y
+ kernel_configure_variable IP6_NF_FILTER y
+ kernel_configure_variable IP6_NF_TARGET_REJECT y
+ kernel_configure_variable IP6_NF_MANGLE y
+ kernel_configure_variable IP6_NF_RAW y
+ kernel_configure_variable NF_NAT_IPV6 y
+ kernel_configure_variable IP6_NF_TARGET_MASQUERADE y
+ kernel_configure_variable IP6_NF_TARGET_NPT y
+}
+
diff --git a/templates/feature/agl-renesas-kernel/50_bblayers.conf.inc b/templates/feature/agl-renesas-kernel/50_bblayers.conf.inc
new file mode 100644
index 00000000..036e0d34
--- /dev/null
+++ b/templates/feature/agl-renesas-kernel/50_bblayers.conf.inc
@@ -0,0 +1,4 @@
+BBLAYERS =+ " \
+ ${METADIR}/meta-agl-devel/meta-renesas-kernel \
+ "
+