summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2022-09-06 23:28:02 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-01-03 14:25:52 +0000
commit17c2c1ed1385f2d01d9f39b297f20a97fb431c7a (patch)
tree93ac7e8f824673f5212b1483759d0e3fdd38bbb3
parent57b39b51a9d7da6d36c811e42bd62453bda58530 (diff)
After the kirkstone, packagegroup-agl-ic-core out the error message in build time. Ex: ERROR: mc:agl-container-cluster:packagegroup-agl-ic-core-1.0-r0 do_package_write_rpm: An allarch packagegroup shouldn't depend on packages which are dynamically renamed (libclusterapi-dbg to libcluster-api-dbg) This error is depend on this commit. https://www.mail-archive.com/openembedded-core@lists.openembedded.org/msg155223.html This patch add "PACKAGE_ARCH = "${TUNE_PKGARCH}"" to package group recipe to fix this issue. Bug-AGL: SPEC-4552 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: I70f56e4a96a658cbcefa48ac688b49382b299879 (cherry picked from commit 73676a6fd1ccede1f804375640b93ddd6b92118e)
-rw-r--r--meta-agl-ic-container/recipes-platform/packagegroups/packagegroup-agl-ic-core.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-platform/packagegroups/packagegroup-agl-ic-core.bb b/meta-agl-ic-container/recipes-platform/packagegroups/packagegroup-agl-ic-core.bb
index d54685c8..75e09d4e 100644
--- a/meta-agl-ic-container/recipes-platform/packagegroups/packagegroup-agl-ic-core.bb
+++ b/meta-agl-ic-container/recipes-platform/packagegroups/packagegroup-agl-ic-core.bb
@@ -5,6 +5,8 @@ HOMEPAGE = "https://confluence.automotivelinux.org/display/IC"
LICENSE = "Apache-2.0"
+PACKAGE_ARCH = "${TUNE_PKGARCH}"
+
inherit packagegroup
PACKAGES = "\