summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-11-02 22:46:54 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-11-02 21:49:17 +0000
commit3ea93e07c091fa6c809589edae7991dfadced8ee (patch)
tree6e377a0e6fbb2165931bb3b68bcbe52ba7d5ad6c
parentc48ce5d693f10404c91815e5ca0e3f3deca08411 (diff)
Allow building vosk-kaldi on arm32 and aarch64needlefish_14.0.2needlefish/14.0.214.0.2
Remove -msse and -msse2 as they are x86 only flags. Bug-AGL: SPEC-4600 Change-Id: I48f52c1c8be7ccfa2db9d70f09d81ad52006a891 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-offline-voice-agent/recipes-vosk/vosk-kaldi/vosk-kaldi_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-vosk/vosk-kaldi/vosk-kaldi_git.bb b/meta-offline-voice-agent/recipes-vosk/vosk-kaldi/vosk-kaldi_git.bb
index b3e021f3..45cf71ff 100644
--- a/meta-offline-voice-agent/recipes-vosk/vosk-kaldi/vosk-kaldi_git.bb
+++ b/meta-offline-voice-agent/recipes-vosk/vosk-kaldi/vosk-kaldi_git.bb
@@ -20,6 +20,20 @@ ALLOW_EMPTY_${PN} = "1"
MYCONF = "--mathlib=OPENBLAS --static --shared --use-cuda=no --fst-root=${STAGING_INCDIR}/../ --fst-version=1.8.0 --openblas-root=${STAGING_INCDIR}/../ "
+# remove x86-specific optimizations
+do_configure:prepend:aarch64(){
+
+sed -i -e "s#-msse -msse2##g" ${S}/makefiles/linux_openblas.mk
+
+}
+
+do_configure:prepend:arm(){
+
+sed -i -e "s#-msse -msse2##g" ${S}/makefiles/linux_openblas.mk
+
+}
+
+
do_configure() {
./configure ${MYCONF}