summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-12-18 18:50:59 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-12-18 19:20:09 +0100
commit468ec1f253f1835814137a4455feb86b9b389993 (patch)
treed042582fe652254d417adb252ce375b375e201dc
parentab3fb8ea5a7e8b60492c41812276481a5211cfe7 (diff)
Also let the user specify the wakeword engine statushalibut_8.0.4halibut/8.0.48.0.4
To enable the wakeword engine you need to have the plugin available and set ALEXA_WAKEWORD in your conf/local.conf to true. Bug-AGL: SPEC-3054 Change-Id: I7f76ab5d6c4818d2825b7059d4005ecbb5682387 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
index f3a6af9d..7e5992bb 100644
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
+++ b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
@@ -10,6 +10,8 @@ SRC_URI = "file://AlexaAutoCoreEngineConfig.json.in"
inherit allarch
+ALEXA_WAKEWORD ??= "false"
+
do_compile () {
if test x"${ALEXA_CLIENTID}" == x"" ; then
@@ -28,7 +30,7 @@ do_compile () {
do_install () {
#replace
- sed -e "s/@@ALEXA_CLIENTID@@/${ALEXA_CLIENTID}/" -e "s/@@ALEXA_SERIALNUMBER@@/${ALEXA_SERIALNUMBER}/" -e "s/@@ALEXA_PRODUCTID@@/${ALEXA_PRODUCTID}/" ${WORKDIR}/AlexaAutoCoreEngineConfig.json.in > ${WORKDIR}/AlexaAutoCoreEngineConfig.json
+ sed -e "s/@@ALEXA_CLIENTID@@/${ALEXA_CLIENTID}/" -e "s/@@ALEXA_SERIALNUMBER@@/${ALEXA_SERIALNUMBER}/" -e "s/@@ALEXA_PRODUCTID@@/${ALEXA_PRODUCTID}/" -e "s/@@WAKEWORD@@/${ALEXA_WAKEWORD}/" ${WORKDIR}/AlexaAutoCoreEngineConfig.json.in > ${WORKDIR}/AlexaAutoCoreEngineConfig.json
# install
install -D -m 644 ${WORKDIR}/AlexaAutoCoreEngineConfig.json ${D}${sysconfdir}/xdg/AGL/AlexaAutoCoreEngineConfig.json