summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2017-05-17 15:07:17 +0900
committerAdministrator <wenlong_zheng_za@mail.toyota.co.jp>2017-06-12 15:20:56 +0900
commit66359c5b0849c3e4ebdfe8e69ee74bb873b73da6 (patch)
tree55bf3be01883ed5a6f51ff0e59d5a63ca12bb7b7
parenta9bbfe1af2ae8ccf79db999e8007b7c6cbc806a1 (diff)
Add oem needs libs,libwebsockets.
Different from apache-websocket in meta-openembedded layer,and qtwebsockets in meta-qt5 layer,libwebsockets is a C library for lightweight websocket clients and servers, can be used in embedded system. Using Tanikawa-san's advice on the packageconfig and for the single recipe only copy it from meta-oe( git://git.openembedded.org/meta-openembedded branch: master commit: 701397952efdb9790a2ea51c7b499f73243dc67b). V2: rebase to master(a9bbfe1af2ae8ccf79db999e8007b7c6cbc806a1). Change-Id: I6464a2b82ca57821959e46c2e2e3193f990e80f7 Signed-off-by: tte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>
-rw-r--r--meta-oem-extra-libs/recipes-connectivity/libwebsockets/libwebsockets_%.bbappend1
-rw-r--r--meta-oem-extra-libs/recipes-connectivity/libwebsockets/libwebsockets_2.1.0.bb28
-rw-r--r--meta-oem-extra-libs/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bbappend1
3 files changed, 30 insertions, 0 deletions
diff --git a/meta-oem-extra-libs/recipes-connectivity/libwebsockets/libwebsockets_%.bbappend b/meta-oem-extra-libs/recipes-connectivity/libwebsockets/libwebsockets_%.bbappend
new file mode 100644
index 00000000..d36c441d
--- /dev/null
+++ b/meta-oem-extra-libs/recipes-connectivity/libwebsockets/libwebsockets_%.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG_remove = "libuv"
diff --git a/meta-oem-extra-libs/recipes-connectivity/libwebsockets/libwebsockets_2.1.0.bb b/meta-oem-extra-libs/recipes-connectivity/libwebsockets/libwebsockets_2.1.0.bb
new file mode 100644
index 00000000..93547998
--- /dev/null
+++ b/meta-oem-extra-libs/recipes-connectivity/libwebsockets/libwebsockets_2.1.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Canonical libwebsockets.org websocket library"
+HOMEPAGE = "https://libwebsockets.org/"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3393a657830d4a118c5a6ed35ba53d0"
+
+DEPENDS = "zlib"
+
+SRC_URI = "https://github.com/warmcat/libwebsockets/archive/v${PV}.tar.gz"
+
+SRC_URI[md5sum] = "4df3be57dee43aeebd54a3ed56568f50"
+SRC_URI[sha256sum] = "bcc96aaa609daae4d3f7ab1ee480126709ef4f6a8bf9c85de40aae48e38cce66"
+
+inherit cmake pkgconfig
+
+PACKAGECONFIG ?= "libuv client server http2 ssl"
+PACKAGECONFIG[client] = "-DLWS_WITHOUT_CLIENT=OFF,-DLWS_WITHOUT_CLIENT=ON,"
+PACKAGECONFIG[http2] = "-DLWS_WITH_HTTP2=ON,-DLWS_WITH_HTTP2=OFF,"
+PACKAGECONFIG[ipv6] = "-DLWS_IPV6=ON,-DLWS_IPV6=OFF,"
+PACKAGECONFIG[libev] = "-DLWS_WITH_LIBEV=ON,-DLWS_WITH_LIBEV=OFF,libev"
+PACKAGECONFIG[libuv] = "-DLWS_WITH_LIBUV=ON,-DLWS_WITH_LIBUV=OFF,libuv"
+PACKAGECONFIG[server] = "-DLWS_WITHOUT_SERVER=OFF,-DLWS_WITHOUT_SERVER=ON,"
+PACKAGECONFIG[ssl] = "-DLWS_WITH_SSL=ON,-DLWS_WITH_SSL=OFF,openssl"
+PACKAGECONFIG[testapps] = "-DLWS_WITHOUT_TESTAPPS=OFF,-DLWS_WITHOUT_TESTAPPS=ON,"
+
+PACKAGES =+ "${PN}-testapps"
+
+FILES_${PN}-dev += "${libdir}/cmake"
+FILES_${PN}-testapps += "${datadir}/libwebsockets-test-server/*"
diff --git a/meta-oem-extra-libs/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bbappend b/meta-oem-extra-libs/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bbappend
index fbd7b976..c2de93c1 100644
--- a/meta-oem-extra-libs/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bbappend
+++ b/meta-oem-extra-libs/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bbappend
@@ -49,4 +49,5 @@ RDEPENDS_${PN} += "\
ppp \
libdatrie \
libthai \
+ libwebsockets \
"