summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKazumasa Mitsunari <knimitz@witz-inc.co.jp>2017-09-05 16:45:04 +0900
committerKazumasa Mitsunari <knimitz@witz-inc.co.jp>2017-09-05 16:45:04 +0900
commit75ea816ddab97e9004b2a1592b45f0b7c96e34e7 (patch)
tree9a0f121e7cdd63241d18c0a964ae779e1d8ae72f
parent62b410682cb607db6830a9a7e7edc86e300f2fc3 (diff)
Add HMI framework layer for HMI recipes
Add HMI framework layer provides HMI recipes in the following url * https://wiki.automotivelinux.org/hmiframework This is still empty layer Change-Id: I5d74d444534c36bcaddc250665f280c764bf0b43 Signed-off-by: Kazumasa Mitsunari <knimitz@witz-inc.co.jp>
-rw-r--r--README.md15
-rw-r--r--meta-hmi-framework/COPYING.MIT17
-rw-r--r--meta-hmi-framework/README.md54
-rw-r--r--meta-hmi-framework/conf/layer.conf10
-rw-r--r--templates/feature/hmi-framework/50_bblayers.conf.inc5
-rw-r--r--templates/feature/hmi-framework/50_local.conf.inc6
6 files changed, 107 insertions, 0 deletions
diff --git a/README.md b/README.md
index 01cdbbd5..63bd9fc0 100644
--- a/README.md
+++ b/README.md
@@ -70,3 +70,18 @@ Reference hardware:
* QEMU (x86-64) - emulated machine: qemux86-64
* Renesas R-Car Gen2 (R-Car M2) - machine: porter
+HMI Framework
+======================================================
+Quick start guide
+-----------------
+To Add HMI Framework, it is necessary to add 'hmi-framework' at source command as same as agl-oem-extra-libs
+
+1. Before build you need prepare agl layers:
+ * You can read it at meta-agl/README-AGL.md
+
+2. build the agl-demo-platform with 'hmi-framework':
+
+```bash
+source meta-agl/scripts/aglsetup.sh -m m3ulcb agl-demo [agl-appfw-smack] [agl-devel] [agl-netboot] hmi-framework
+```
+
diff --git a/meta-hmi-framework/COPYING.MIT b/meta-hmi-framework/COPYING.MIT
new file mode 100644
index 00000000..89de3547
--- /dev/null
+++ b/meta-hmi-framework/COPYING.MIT
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/meta-hmi-framework/README.md b/meta-hmi-framework/README.md
new file mode 100644
index 00000000..e0bd2e0a
--- /dev/null
+++ b/meta-hmi-framework/README.md
@@ -0,0 +1,54 @@
+This README file contains information on the contents of the
+hmi-framework layer.
+
+Please see the corresponding sections below for details.
+
+
+HMI Framework
+================
+meta-hmi-framework is the layer providing HMI framework.
+HMI framework provides HMI resource(right) management. Resource contains sound, window, input to control.
+This is based on the document in https://wiki.automotivelinux.org/hmiframework
+
+Maintainers:
+ Takeshi Hoshina<takeshi_hoshina@mail.toyota.co.jp>
+ Hiroshi Kojima<Hiroshi_Kojima@mentor.com>
+ Kazumasa Mitsunari<knimitz@witz-inc.co.jp>
+
+
+How to enable the framework
+=================
+In order to enable the HMI Framework features, the following line has to be enabled in local.conf
+
+IMAGE_INSTALL_append += ""
+
+Reference
+=================
+https://wiki.automotivelinux.org/hmiframework
+
+
+I. Adding the hmi-framework layer to your build
+=================================================
+
+--- replace with specific instructions for the hmi-framework layer ---
+
+In order to use this layer, you need to make the build system aware of
+it.
+
+Assuming the hmi-framework layer exists at the top-level of your
+yocto build tree, you can add it to the build system by adding the
+location of the hmi-framework layer to bblayers.conf, along with any
+other layers needed. e.g.:
+
+ BBLAYERS ?= " \
+ /path/to/yocto/meta \
+ /path/to/yocto/meta-poky \
+ /path/to/yocto/meta-yocto-bsp \
+ /path/to/yocto/meta-hmi-framework \
+ "
+
+
+II. Misc
+========
+
+--- replace with specific information about the hmi-framework layer ---
diff --git a/meta-hmi-framework/conf/layer.conf b/meta-hmi-framework/conf/layer.conf
new file mode 100644
index 00000000..e56ee21c
--- /dev/null
+++ b/meta-hmi-framework/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "hmi-framework"
+BBFILE_PATTERN_hmi-framework = "^${LAYERDIR}/"
+BBFILE_PRIORITY_hmi-framework = "8"
diff --git a/templates/feature/hmi-framework/50_bblayers.conf.inc b/templates/feature/hmi-framework/50_bblayers.conf.inc
new file mode 100644
index 00000000..8fbfa728
--- /dev/null
+++ b/templates/feature/hmi-framework/50_bblayers.conf.inc
@@ -0,0 +1,5 @@
+
+BBLAYERS =+ " \
+ ${METADIR}/meta-agl-devel/meta-hmi-framework \
+ "
+
diff --git a/templates/feature/hmi-framework/50_local.conf.inc b/templates/feature/hmi-framework/50_local.conf.inc
new file mode 100644
index 00000000..2ee6737f
--- /dev/null
+++ b/templates/feature/hmi-framework/50_local.conf.inc
@@ -0,0 +1,6 @@
+# In order to enable the agl virtualization features (agl-egvirt),
+# each supported board needs to add in one of its configuration
+# files (see for instance meta-agl/meta-agl-bsp/conf/include)
+# the following line:
+#
+IMAGE_INSTALL_append = ""