summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-11-02 11:56:53 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-11-02 11:56:56 +0100
commit8e7e0ea31dcec482e10c5f153b51f01c6576f281 (patch)
tree0fc754b7f8fcc085c8b34ca2c0fc9fc1c56e15f1
parentb94ec6173a2e28507522e7ece1fbb3fe8e06245d (diff)
Recipe style fixes in meta-hmi-framework
This change applies the standard bitbake recipe layout, especially it fixes: - DEPENDS before inherit (as we might DEPENDS += in the inherit !) - 'S =' below SRC_URI (style nitpick) - DESCRIPTION being present These changes are just 'formatting' but worst case we see a difference in DEPENDS due to the corrected ordering. Change-Id: I9c82114c4f4e86a59e73e3ebcdc063b2ed6bd4f1 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/agl-service-homescreen-2017/agl-service-homescreen-2017_git.bb5
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb9
-rw-r--r--meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb15
-rw-r--r--meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb8
-rw-r--r--meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb14
-rw-r--r--meta-hmi-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb8
6 files changed, 35 insertions, 24 deletions
diff --git a/meta-hmi-framework/recipes-demo-hmi/agl-service-homescreen-2017/agl-service-homescreen-2017_git.bb b/meta-hmi-framework/recipes-demo-hmi/agl-service-homescreen-2017/agl-service-homescreen-2017_git.bb
index da52f9d9..f461c9d3 100644
--- a/meta-hmi-framework/recipes-demo-hmi/agl-service-homescreen-2017/agl-service-homescreen-2017_git.bb
+++ b/meta-hmi-framework/recipes-demo-hmi/agl-service-homescreen-2017/agl-service-homescreen-2017_git.bb
@@ -1,13 +1,14 @@
SUMMARY = "Homescreen binding and client library for application"
DESCRIPTION = "Homescreen 2017 is the binding library"
HOMEPAGE = "https://git.automotivelinux.org/apps/agl-service-homescreen-2017"
-SECTION = "HMI"
+SECTION = "HMI"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-inherit cmake aglwgt
DEPENDS = "dbus glib-2.0 af-binder json-c"
+inherit cmake aglwgt
+
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen-2017;protocol=https;branch=master"
SRCREV = "087ddd64698d8634cd748e0341a6c17e0a6ca134"
S = "${WORKDIR}/git"
diff --git a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
index 1c75a69c..a6927d08 100644
--- a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
+++ b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
@@ -1,12 +1,10 @@
SUMMARY = "AGL Home Screen 2017 Application"
-DESCRIPTION = "AGL Home Screen 2017 Application"
+DESCRIPTION = "AGL Home Screen 2017 Application build with recipe method"
HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/gitweb?p=staging/homescreen-2017.git"
-S = "${WORKDIR}/git/"
SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-inherit qmake5 systemd pkgconfig aglwgt
DEPENDS = "\
qtbase \
qtdeclarative \
@@ -18,7 +16,10 @@ DEPENDS = "\
libwindowmanager \
"
+inherit qmake5 systemd pkgconfig aglwgt
+
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/homescreen-2017;protocol=https;branch=master"
-SRCREV = "4940d001f08bec6fd68293efcbd6673a9ffce65e"
+SRCREV = "4940d001f08bec6fd68293efcbd6673a9ffce65e"
+S = "${WORKDIR}/git/"
PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
diff --git a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
index a9fcaa67..e9faa594 100644
--- a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
+++ b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
@@ -1,19 +1,22 @@
SUMMARY = "Window Manager service binding for applications"
-DESCRIPTION = "Window Manager 2017 is the service binding for controlling rendering rights \
- Applications requests to render itself, then Window Manager check policy and notify layout to respective applications \
- "
+DESCRIPTION = "Window Manager 2017 is the service binding for controlling \
+ rendering rights. Applications request to render itself, \
+ then Window Manager checks the policy and notifies the \
+ layout to the respective applications \
+ "
HOMEPAGE = "https://wiki.automotivelinux.org/windowmanager"
-SECTION = "graphics"
+SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93 \
file://LICENSE.MIT;md5=a7514fe5664902e337bd8a4443d8f348"
+
DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
+inherit cmake aglwgt
+
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=master"
SRCREV = "3772dc5dc1b89ac101134d02529bde7185e68948"
S = "${WORKDIR}/git"
-inherit cmake aglwgt
-
#If you would like to output log, uncomment out
EXTRA_OECMAKE_append_agl-devel = " -DENABLE_DEBUG_OUTPUT=ON "
diff --git a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
index d291ef81..50bbe979 100644
--- a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
+++ b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
@@ -1,12 +1,14 @@
SUMMARY = "Window Manager client library for applications"
-SECTION = "graphics"
+DESCRIPTION = "Window Manager client library for application built with recipe"
+SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
DEPENDS = "af-binder json-c"
RDEPENDS_${PN} = "agl-service-windowmanager-2017"
+inherit cmake
+
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/libwindowmanager.git;protocol=https;branch=master"
SRCREV = "71d3c9ee49ece6063ea93090b3661df6a90dd1de"
S = "${WORKDIR}/git"
-
-inherit cmake
diff --git a/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb b/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb
index e2de4d8d..13cd800c 100644
--- a/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb
+++ b/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb
@@ -1,17 +1,19 @@
SUMMARY = "Sound Manager binding"
DESCRIPTION = "Sound Manager is the service binding to communicate \
- with Genivi Audio Manager. Genivi Audio Manager is the policy manager \
- for sound. It controls volume and routing according to various situations.\
- "
+ with Genivi Audio Manager. Genivi Audio Manager is \
+ the policy manager for sound. It controls volume \
+ and routing according to various situations. \
+ "
HOMEPAGE = "https://wiki.automotivelinux.org/soundmanager"
-SECTION = "multimedia"
+SECTION = "multimedia"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
DEPENDS = "dbus glib-2.0 af-binder json-c"
RDEPENDS_${PN} = "audiomanager audiomanager-plugins"
+inherit cmake aglwgt
+
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-soundmanager-2017;protocol=https;branch=master"
SRCREV = "71e9700fe906fff4f111bc70d025912ee5dd095a"
S = "${WORKDIR}/git"
-
-inherit cmake aglwgt
diff --git a/meta-hmi-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb b/meta-hmi-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb
index 8801b754..5bf325a3 100644
--- a/meta-hmi-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb
+++ b/meta-hmi-framework/recipes-multimedia/libsoundmanager/libsoundmanager_git.bb
@@ -1,13 +1,15 @@
SUMMARY = "Sound Manager client library for applications"
+DESCRIPTION = "Sound Manager client library for applications built with recipe"
HOMEPAGE = "https://wiki.automotivelinux.org/soundmanager"
-SECTION = "multimedia"
+SECTION = "multimedia"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
DEPENDS = "af-binder json-c"
RDEPENDS_${PN} = "agl-service-soundmanager-2017"
+inherit cmake
+
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/libsoundmanager.git;protocol=https;branch=master"
SRCREV = "cda4a958e85d397bae142fbe6068a3e17d4aa935"
S = "${WORKDIR}/git"
-
-inherit cmake