summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTakashi Matsuzawa <tmatsuzawa@xevo.com>2017-07-23 22:19:55 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-24 21:48:21 +0000
commitaff7892a9784bcb33aaee5da07091de2b8672c88 (patch)
tree3a4f8f709b8cfdf6d884f453349bf8ad25706a1a
parentf84701bf72a41632abc8724210074bac510d0f5c (diff)
Fix libthai (oem-extra-libs) build breakdab_4.0.1dab_4.0.0dab/4.0.1dab/4.0.04.0.14.0.0
Bug-AGL: SPEC-771 Fix in libdatrie recipe so that libdatrie-native can be properly used to build libthai. Alternatively EXTRA_OECONF += "--disable-dict" can be added to libthai, but I guess (since I did not add libthai) it is not expected. Update: I also needed libdatrie-native dependency in libthai.bb Update2: Fix build breaks for imagemagick and protobuf as well Change-Id: I175a34f321841d6aa1cdabac69c67d590d313043 Signed-off-by: Takashi Matsuzawa <tmatsuzawa@xevo.com>
-rw-r--r--meta-oem-extra-libs/conf/layer.conf4
-rwxr-xr-xmeta-oem-extra-libs/recipes-support/libdatrie/libdatrie_0.2.9.bb4
-rwxr-xr-xmeta-oem-extra-libs/recipes-support/libthai/libthai_0.1.20.bb2
3 files changed, 7 insertions, 3 deletions
diff --git a/meta-oem-extra-libs/conf/layer.conf b/meta-oem-extra-libs/conf/layer.conf
index 8eb09a28..a6c8e2aa 100644
--- a/meta-oem-extra-libs/conf/layer.conf
+++ b/meta-oem-extra-libs/conf/layer.conf
@@ -9,3 +9,7 @@ BBFILE_COLLECTIONS += "oem-extra-libs"
BBFILE_PATTERN_oem-extra-libs = "^${LAYERDIR}/"
BBFILE_PRIORITY_oem-extra-libs = "7"
+# Fixing build errors
+SECURITY_CFLAGS_pn-imagemagick = "${SECURITY_NO_PIE_CFLAGS}"
+SECURITY_CFLAGS_pn-protobuf = "${SECURITY_NO_PIE_CFLAGS}"
+
diff --git a/meta-oem-extra-libs/recipes-support/libdatrie/libdatrie_0.2.9.bb b/meta-oem-extra-libs/recipes-support/libdatrie/libdatrie_0.2.9.bb
index f317eb21..44fd0b47 100755
--- a/meta-oem-extra-libs/recipes-support/libdatrie/libdatrie_0.2.9.bb
+++ b/meta-oem-extra-libs/recipes-support/libdatrie/libdatrie_0.2.9.bb
@@ -13,7 +13,7 @@ inherit autotools pkgconfig
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
-SRC_URI = "http://linux.thai.net/pub/thailinux/software/libthai/${PN}-${PV}.tar.xz"
+SRC_URI = "http://linux.thai.net/pub/thailinux/software/libthai/${BPN}-${PV}.tar.xz"
SRC_URI[md5sum] = "687624f374e748de81b01399736bb735"
SRC_URI[sha256sum] = "d980713e7ad8e19cf3b54ee0173782b94332af8e7e4e936dde01d2cd72e1da1d"
@@ -24,5 +24,5 @@ PACKAGES =+ "${PN}1-bin"
FILES_${PN}1-bin += "${bindir}/*"
-#BBCLASSEXTEND += "native"
+BBCLASSEXTEND += "native"
diff --git a/meta-oem-extra-libs/recipes-support/libthai/libthai_0.1.20.bb b/meta-oem-extra-libs/recipes-support/libthai/libthai_0.1.20.bb
index ce8dc17c..0271da08 100755
--- a/meta-oem-extra-libs/recipes-support/libthai/libthai_0.1.20.bb
+++ b/meta-oem-extra-libs/recipes-support/libthai/libthai_0.1.20.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Thai language support routines"
LICENSE = "LGPL"
-DEPENDS = "libdatrie"
+DEPENDS = "libdatrie libdatrie-native"
SRC_URI = "http://linux.thai.net/pub/thailinux/software/libthai/${PN}-${PV}.tar.xz"