summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2022-02-04 10:23:54 -0800
committerJoel Winarske <joel.winarske@gmail.com>2022-02-04 16:49:23 -0800
commitbbdf5e3bdb72bfe5516cec63573b117d97ed6bc6 (patch)
tree59a1b0b12c0c66b29eaa3a6c4c9e8c4b9aaaf022
parent01a6a10fe4447f129b5628892193945ffbeeedc0 (diff)
- ivi-homescreen updates * 32-bit build support * EGL build time parameters * Remove build time dependency of libflutter_engine.so. Loads libflutter_engine.so at runtime. * Functional Mouse cursor plugin. Adds --t {theme name} CLI option * DEBUG Check fix for mouse * third party flutter source update * Re-work common code for plugins * Text plugin functional and enabled by default * Use check_ipo_supported to determine lto * Dart message callback -> print to stdout * Support building for iMX8/Vivante EGL * Use revised meta-flutter layout for defining systemd service - move to latest commit for Igalia Flutter Demo application Signed-off-by: Joel Winarske <joel.winarske@gmail.com> Change-Id: Icfb7292537b3300e3af778c4934551c5d93f1727
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb2
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_%.bbappend8
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_%.bbappend9
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-release_%.bbappend7
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc2
-rw-r--r--templates/feature/agl-flutter/50_local.conf.inc7
6 files changed, 28 insertions, 7 deletions
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb
index 1f57cd7e..09250d6b 100644
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb
+++ b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRC_URI = "git://github.com/felipeerias/flutter_homescreen.git;protocol=https;branch=main"
-SRCREV = "283f915354dcc81410b30534c1eda063d0e78888"
+SRCREV = "08bf271f7f1f14153a41005718a2090fa8e783f0"
S = "${WORKDIR}/git"
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_%.bbappend
index 9727092c..191eb590 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_%.bbappend
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_%.bbappend
@@ -1 +1,9 @@
require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', '${BPN}_aglflutter.inc', '', d)}
+
+IVI_HOMESCREEN_APP_OVERRIDE = "--a=/usr/share/gallery"
+SERVICE_EXEC_START_PARAMS = "--observatory-host 0.0.0.0 --observatory-port 1234"
+
+SERVICE_UNIT = "Requires=weston.service\nAfter=weston.service"
+SERVICE_USER_GROUP = "User=weston\nGroup=weston"
+SERVICE_RESTART = ""
+SERVICE_ENVIRONMENT = "Environment=XDG_RUNTIME_DIR=/run/user/200"
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_%.bbappend
index 9727092c..570d5025 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_%.bbappend
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_%.bbappend
@@ -1 +1,10 @@
require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', '${BPN}_aglflutter.inc', '', d)}
+
+IVI_HOMESCREEN_APP_OVERRIDE = "--a=/usr/share/gallery"
+SERVICE_EXEC_START_PARAMS = "--observatory-host 0.0.0.0 --observatory-port 1234 --start-paused"
+
+SERVICE_UNIT = "Requires=weston.service\nAfter=weston.service"
+SERVICE_USER_GROUP = "User=weston\nGroup=weston"
+SERVICE_RESTART = ""
+SERVICE_ENVIRONMENT = "Environment=XDG_RUNTIME_DIR=/run/user/200"
+
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-release_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-release_%.bbappend
index 9727092c..fe5bb164 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-release_%.bbappend
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-release_%.bbappend
@@ -1 +1,8 @@
require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', '${BPN}_aglflutter.inc', '', d)}
+
+IVI_HOMESCREEN_APP_OVERRIDE = "--a=/usr/share/gallery"
+
+SERVICE_UNIT = "Requires=weston.service\nAfter=weston.service"
+SERVICE_USER_GROUP = "User=weston\nGroup=weston"
+SERVICE_RESTART = ""
+SERVICE_ENVIRONMENT = "Environment=XDG_RUNTIME_DIR=/run/user/200"
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc
index 233e911c..cfffd69f 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc
@@ -1,2 +1,2 @@
-SRCREV = "08f074ccc42c1129cf8587f48970bdfbd154693a"
+SRCREV = "87c5567703906cfc2acd9280b71580fb97724abe"
diff --git a/templates/feature/agl-flutter/50_local.conf.inc b/templates/feature/agl-flutter/50_local.conf.inc
index 23bb0ebc..3968bf2b 100644
--- a/templates/feature/agl-flutter/50_local.conf.inc
+++ b/templates/feature/agl-flutter/50_local.conf.inc
@@ -1,8 +1,5 @@
-# Set Flutter Channel
-FLUTTER_CHANNEL = "dev"
-
-# Build engine with runtime=release
-PACKAGECONFIG:pn-flutter-engine = "embedder-for-target disable-desktop-embeddings fontconfig mode-release"
+# Set Flutter SDK tag
+FLUTTER_SDK_TAG = "2.8.0-3.3.pre"
# Include Flutter SDK in SDK
TOOLCHAIN_HOST_TASK:append = " nativesdk-flutter-sdk"