summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenta <murakami.kenta002@jp.panasonic.com>2024-10-03 10:20:05 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-10-16 11:48:48 +0000
commite08ed699e9b0857964822fab6ede324b624abbbf (patch)
tree7086f64cdf9926249dd1818e2326dc586adb455a
parentf818d656ed9de2def39840b141b153ddfa22a5ba (diff)
Unified HMI: Add rvgpu-wlproxy
rvgpu-wlproxy works as wayland server and when combined with remote-virtio-gpu, realize the remote rendering with flutter app (overall wayland app). Bug-AGL: SPEC-5253 Change-Id: I99fa0d4df528c75bccf5bf8aa261b0c39a118252 Signed-off-by: Kenta <murakami.kenta002@jp.panasonic.com>
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb19
-rw-r--r--meta-uhmi/meta-rvgpu/recipes-platform/packagegroups/packagegroup-rvgpu.bb2
2 files changed, 20 insertions, 1 deletions
diff --git a/meta-uhmi/meta-rvgpu/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb b/meta-uhmi/meta-rvgpu/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb
new file mode 100644
index 00000000..5f6a70f2
--- /dev/null
+++ b/meta-uhmi/meta-rvgpu/recipes-graphics/rvgpu-wlproxy/rvgpu-wlproxy_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Panasonic UHMI RVGPU Wayland Proxy"
+DEPENDS = " virtual/libgbm libinput libxkbcommon"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a8a0cf4075753e7d7e8c948171357af0"
+
+SRCREV ="067d46a8977852afb8b503bd7d833b9037673db4"
+BRANCH ?= "main"
+
+SRC_URI = " \
+ git://github.com/unified-hmi/rvgpu-wlproxy.git;protocol=https;branch=${BRANCH} \
+"
+PV = "0.0+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig cmake
+
+FILES:${PN} += "/usr/bin/*"
diff --git a/meta-uhmi/meta-rvgpu/recipes-platform/packagegroups/packagegroup-rvgpu.bb b/meta-uhmi/meta-rvgpu/recipes-platform/packagegroups/packagegroup-rvgpu.bb
index 856b2584..d7f55043 100644
--- a/meta-uhmi/meta-rvgpu/recipes-platform/packagegroups/packagegroup-rvgpu.bb
+++ b/meta-uhmi/meta-rvgpu/recipes-platform/packagegroups/packagegroup-rvgpu.bb
@@ -7,5 +7,5 @@ RDEPENDS:${PN} += " \
remote-virtio-gpu \
virtio-loopback-driver \
mesa-virtio \
- weston \
+ rvgpu-wlproxy \
"