summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2022-03-10 16:57:28 -0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-03-11 19:02:38 +0000
commitf12c1d8d314454088bef2120468e2881ab2ce960 (patch)
treed4c0317e9e79fb89ce95ba597aba75e88df8ff14
parentab6910459e87b569ee62c5991376aa78e85602f3 (diff)
-Lock ivi-homescreen version v2 (jsmoeller): consolidate and apply missing include file Bug-AGL: SPEC-4297 Signed-off-by: Joel Winarske <joel.winarske@gmail.com> Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I189d86b353c6a2f9c1691cc8186992887c25d547
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_%.bbappend9
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_aglflutter.inc2
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_%.bbappend9
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_aglflutter.inc4
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-release_%.bbappend11
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc10
-rw-r--r--templates/feature/agl-flutter/50_local.conf.inc3
7 files changed, 23 insertions, 25 deletions
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_%.bbappend
index 191eb590..ea695b94 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_%.bbappend
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_%.bbappend
@@ -1,9 +1,2 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'ivi-homescreen_aglflutter.inc', '', d)}
require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', '${BPN}_aglflutter.inc', '', d)}
-
-IVI_HOMESCREEN_APP_OVERRIDE = "--a=/usr/share/gallery"
-SERVICE_EXEC_START_PARAMS = "--observatory-host 0.0.0.0 --observatory-port 1234"
-
-SERVICE_UNIT = "Requires=weston.service\nAfter=weston.service"
-SERVICE_USER_GROUP = "User=weston\nGroup=weston"
-SERVICE_RESTART = ""
-SERVICE_ENVIRONMENT = "Environment=XDG_RUNTIME_DIR=/run/user/200"
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_aglflutter.inc
new file mode 100644
index 00000000..ebc18064
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-debug_aglflutter.inc
@@ -0,0 +1,2 @@
+# debug package specifics
+SERVICE_EXEC_START_PARAMS = "--observatory-host 0.0.0.0 --observatory-port 1234"
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_%.bbappend
index 570d5025..ed5c8805 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_%.bbappend
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_%.bbappend
@@ -1,10 +1,3 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'ivi-homescreen_aglflutter.inc', '', d)}
require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', '${BPN}_aglflutter.inc', '', d)}
-IVI_HOMESCREEN_APP_OVERRIDE = "--a=/usr/share/gallery"
-SERVICE_EXEC_START_PARAMS = "--observatory-host 0.0.0.0 --observatory-port 1234 --start-paused"
-
-SERVICE_UNIT = "Requires=weston.service\nAfter=weston.service"
-SERVICE_USER_GROUP = "User=weston\nGroup=weston"
-SERVICE_RESTART = ""
-SERVICE_ENVIRONMENT = "Environment=XDG_RUNTIME_DIR=/run/user/200"
-
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_aglflutter.inc
new file mode 100644
index 00000000..0d3176a9
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-profile_aglflutter.inc
@@ -0,0 +1,4 @@
+# profile specific commands
+SERVICE_EXEC_START_PARAMS = "--observatory-host 0.0.0.0 --observatory-port 1234 --start-paused"
+
+
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-release_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-release_%.bbappend
index fe5bb164..05cac727 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-release_%.bbappend
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen-release_%.bbappend
@@ -1,8 +1,3 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', '${BPN}_aglflutter.inc', '', d)}
-
-IVI_HOMESCREEN_APP_OVERRIDE = "--a=/usr/share/gallery"
-
-SERVICE_UNIT = "Requires=weston.service\nAfter=weston.service"
-SERVICE_USER_GROUP = "User=weston\nGroup=weston"
-SERVICE_RESTART = ""
-SERVICE_ENVIRONMENT = "Environment=XDG_RUNTIME_DIR=/run/user/200"
+require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'ivi-homescreen_aglflutter.inc', '', d)}
+# not used atm
+#require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', '${BPN}_aglflutter.inc', '', d)}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc
index cfffd69f..348171af 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc
@@ -1,2 +1,10 @@
-
+# Pinned SRCREV
SRCREV = "87c5567703906cfc2acd9280b71580fb97724abe"
+
+# AGL specifics
+IVI_HOMESCREEN_APP_OVERRIDE = "--a=/usr/share/gallery"
+
+SERVICE_UNIT = "Requires=weston.service\nAfter=weston.service"
+SERVICE_USER_GROUP = "User=weston\nGroup=weston"
+SERVICE_RESTART = ""
+SERVICE_ENVIRONMENT = "Environment=XDG_RUNTIME_DIR=/run/user/200"
diff --git a/templates/feature/agl-flutter/50_local.conf.inc b/templates/feature/agl-flutter/50_local.conf.inc
index 3968bf2b..83ab64b3 100644
--- a/templates/feature/agl-flutter/50_local.conf.inc
+++ b/templates/feature/agl-flutter/50_local.conf.inc
@@ -3,3 +3,6 @@ FLUTTER_SDK_TAG = "2.8.0-3.3.pre"
# Include Flutter SDK in SDK
TOOLCHAIN_HOST_TASK:append = " nativesdk-flutter-sdk"
+
+# Include agl-specific defaults
+require conf/include/agl-flutter.inc