summaryrefslogtreecommitdiffstats
path: root/meta-agl-drm-lease/recipes-core
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-11 17:09:44 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-31 09:16:39 +0000
commit95e1b466426763d761b171677c86b36f925c9d88 (patch)
tree68ac121a638b8171799357db294ad66c2073e40b /meta-agl-drm-lease/recipes-core
parent70cd4a0658ec43ae7b1195019d1e2d32df384835 (diff)
Ensure meta-agl-drm-lease does pass yocto-check-layer and has run-yocto-check-layer.sh scripts
Ensure the layers do pass again and that the scripts are up-to-date. Bug-AGL: SPEC-4680 Bug-AGL: SPEC-4686 Change-Id: Id1279d4a43b89d50731dd85e9347d35d524e14b7 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-drm-lease/recipes-core')
-rw-r--r--meta-agl-drm-lease/recipes-core/psplash/psplash_agl-drm-lease.inc43
-rw-r--r--meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend44
2 files changed, 44 insertions, 43 deletions
diff --git a/meta-agl-drm-lease/recipes-core/psplash/psplash_agl-drm-lease.inc b/meta-agl-drm-lease/recipes-core/psplash/psplash_agl-drm-lease.inc
new file mode 100644
index 00000000..53adec9c
--- /dev/null
+++ b/meta-agl-drm-lease/recipes-core/psplash/psplash_agl-drm-lease.inc
@@ -0,0 +1,43 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+# drm-backend backport from:
+# https://patchwork.yoctoproject.org/project/yocto/cover/20220425075954.10427-1-vasyl.vavrychuk@opensynergy.com/
+SRC_URI += " \
+ file://0001-Fix-duplicated-definition-of-bool.patch \
+ file://0002-Trim-trailing-spaces.patch \
+ file://0003-Fix-unused-result-warnings.patch \
+ file://0004-Remove-unused-save_termios.patch \
+ file://0005-Remove-psplash-fb.h-from-psplash.h.patch \
+ file://0006-Extract-plot-pixel-from-psplash-fb.patch \
+ file://0007-Extract-draw-rect-image-from-psplash-fb.patch \
+ file://0008-Extract-draw-font-from-psplash-fb.patch \
+ file://0009-psplash.c-Make-psplash_draw_-msg-progress-independen.patch \
+ file://0010-Rework-flip-as-function-pointer.patch \
+ file://0011-Import-drm-howto-modeset.c-as-psplash-drm.c.patch \
+ file://0012-Implement-drm-backend.patch \
+ file://0013-Reverse-modeset_list.patch \
+ file://0014-psplash-drm.c-Allocate-resources-only-for-the-first-.patch \
+ file://0015-psplash-drm.c-Implement-double-buffering.patch \
+ "
+
+# drm-lease support from:
+# https://github.com/agl-ic-eg/meta-agl-demo/tree/main/recipes-core/psplash
+SRC_URI += " \
+ file://0016-Imprement-drm-lease-support.patch \
+ file://0017-drm-lease-Fix-incorrect-drawing-with-portrait-orient.patch \
+ file://psplash-drmlease.conf \
+ "
+
+# Licesnse checksum was changed by above patches
+LIC_FILES_CHKSUM = "file://psplash.h;beginline=1;endline=8;md5=db1ed16abf4be6de3d79201093ac4f07"
+
+PACKAGECONFIG:append = " drm drm-lease"
+
+PACKAGECONFIG[drm] = "--enable-drm,,libdrm"
+PACKAGECONFIG[drm-lease] = "--enable-drm-lease,,drm-lease-manager"
+
+do_install:append () {
+ # Install override
+ install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
+ install -m 0644 ${WORKDIR}/psplash-drmlease.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+}
diff --git a/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend b/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
index 53adec9c..548e209d 100644
--- a/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
@@ -1,43 +1 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-
-# drm-backend backport from:
-# https://patchwork.yoctoproject.org/project/yocto/cover/20220425075954.10427-1-vasyl.vavrychuk@opensynergy.com/
-SRC_URI += " \
- file://0001-Fix-duplicated-definition-of-bool.patch \
- file://0002-Trim-trailing-spaces.patch \
- file://0003-Fix-unused-result-warnings.patch \
- file://0004-Remove-unused-save_termios.patch \
- file://0005-Remove-psplash-fb.h-from-psplash.h.patch \
- file://0006-Extract-plot-pixel-from-psplash-fb.patch \
- file://0007-Extract-draw-rect-image-from-psplash-fb.patch \
- file://0008-Extract-draw-font-from-psplash-fb.patch \
- file://0009-psplash.c-Make-psplash_draw_-msg-progress-independen.patch \
- file://0010-Rework-flip-as-function-pointer.patch \
- file://0011-Import-drm-howto-modeset.c-as-psplash-drm.c.patch \
- file://0012-Implement-drm-backend.patch \
- file://0013-Reverse-modeset_list.patch \
- file://0014-psplash-drm.c-Allocate-resources-only-for-the-first-.patch \
- file://0015-psplash-drm.c-Implement-double-buffering.patch \
- "
-
-# drm-lease support from:
-# https://github.com/agl-ic-eg/meta-agl-demo/tree/main/recipes-core/psplash
-SRC_URI += " \
- file://0016-Imprement-drm-lease-support.patch \
- file://0017-drm-lease-Fix-incorrect-drawing-with-portrait-orient.patch \
- file://psplash-drmlease.conf \
- "
-
-# Licesnse checksum was changed by above patches
-LIC_FILES_CHKSUM = "file://psplash.h;beginline=1;endline=8;md5=db1ed16abf4be6de3d79201093ac4f07"
-
-PACKAGECONFIG:append = " drm drm-lease"
-
-PACKAGECONFIG[drm] = "--enable-drm,,libdrm"
-PACKAGECONFIG[drm-lease] = "--enable-drm-lease,,drm-lease-manager"
-
-do_install:append () {
- # Install override
- install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
- install -m 0644 ${WORKDIR}/psplash-drmlease.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
-}
+require ${@bb.utils.contains('AGL_FEATURES', 'agl-drm-lease', 'psplash_agl-drm-lease.inc', '', d)}