summaryrefslogtreecommitdiffstats
path: root/meta-agl-drm-lease/recipes-support
diff options
context:
space:
mode:
authorDamian Hobson-Garcia <dhobsong@igel.co.jp>2022-04-08 12:34:23 +0900
committerDamian Hobson-Garcia <dhobsong@igel.co.jp>2022-04-27 13:01:09 +0900
commitcdbc49db38c274c880d2372a1d0fe648de920a68 (patch)
tree4ce6d7bf157a2e29aa846355a12f0489385de83e /meta-agl-drm-lease/recipes-support
parenta3614219b71e146ea91b4fdf361a23c2b47abe94 (diff)
drm-lease-manager: Add configuration file suppport
Use latest drm-lease-manager version and add a generic lease manager configuration file. Platforms should override this with something appropriate for their system. Bug-AGL: SPEC-3815 Change-Id: I3c0a4b137e53dab7ff2782791cfca951e4c14e13 Signed-off-by: Damian Hobson-Garcia <dhobsong@igel.co.jp>
Diffstat (limited to 'meta-agl-drm-lease/recipes-support')
-rw-r--r--meta-agl-drm-lease/recipes-support/tomlc99/tomlc99_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-agl-drm-lease/recipes-support/tomlc99/tomlc99_git.bb b/meta-agl-drm-lease/recipes-support/tomlc99/tomlc99_git.bb
new file mode 100644
index 00000000..6df5ae5d
--- /dev/null
+++ b/meta-agl-drm-lease/recipes-support/tomlc99/tomlc99_git.bb
@@ -0,0 +1,21 @@
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=95bbe2f9180443b5dcef3fb959804a65"
+
+SRC_URI = "git://github.com/cktan/tomlc99;protocol=https;branch=master"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "034b23ed3e4e5ee5345040eabed470f204d7f668"
+
+S = "${WORKDIR}/git"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_install () {
+ oe_runmake install prefix=${D}/${prefix}
+
+ ln -rs ${D}/${prefix}/lib/libtoml.so.0.0 ${D}${prefix}/lib/libtoml.so
+
+ sed 's:^prefix=.*:prefix=${prefix}:' ${S}/libtoml.pc.sample > libtoml.pc
+ install -d ${D}${prefix}/lib/pkgconfig
+ install libtoml.pc ${D}${prefix}/lib/pkgconfig/
+}