summaryrefslogtreecommitdiffstats
path: root/meta-agl-drm-lease
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2023-05-21 14:04:04 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2023-05-30 00:00:28 +0900
commit07c3016fbc186420c425544fb434ecdf16f563c6 (patch)
tree7d8a4384a2a80f68e7507a645226d6c2748ecf1f /meta-agl-drm-lease
parent261769808117585a84046e8d3ab566f40d31d5da (diff)
Improvement to psplash recipe using service override
Last psplash patch has some HACK implementation for drl lease support. It cause complex change to psplash service file. This patch fix this issue reusing sandbox/ishii.hiroyuki/psplash-drm, that is worked by ishii hiroyuki. Bug-AGL: SPEC-4804 Change-Id: I350a4627b8062ec418016a72b20af2e9d0f2a9a0 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'meta-agl-drm-lease')
-rw-r--r--meta-agl-drm-lease/recipes-core/psplash/files/psplash-drmlease.conf3
-rw-r--r--meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend12
2 files changed, 9 insertions, 6 deletions
diff --git a/meta-agl-drm-lease/recipes-core/psplash/files/psplash-drmlease.conf b/meta-agl-drm-lease/recipes-core/psplash/files/psplash-drmlease.conf
new file mode 100644
index 00000000..28bf19c4
--- /dev/null
+++ b/meta-agl-drm-lease/recipes-core/psplash/files/psplash-drmlease.conf
@@ -0,0 +1,3 @@
+[Service]
+Environment=PSPLASH_ARGS='--drm --drm-lease lease'
+Environment=DLM_RUNTIME_PATH=/var/display/drm-lease-manager
diff --git a/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend b/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
index 56650669..53adec9c 100644
--- a/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
@@ -25,19 +25,19 @@ SRC_URI += " \
SRC_URI += " \
file://0016-Imprement-drm-lease-support.patch \
file://0017-drm-lease-Fix-incorrect-drawing-with-portrait-orient.patch \
+ file://psplash-drmlease.conf \
"
# Licesnse checksum was changed by above patches
LIC_FILES_CHKSUM = "file://psplash.h;beginline=1;endline=8;md5=db1ed16abf4be6de3d79201093ac4f07"
-PACKAGECONFIG[drm] = "--enable-drm,,libdrm"
-PSPLASH_ARGS += "${@bb.utils.contains('PACKAGECONFIG', 'drm', '--drm', '', d)}"
+PACKAGECONFIG:append = " drm drm-lease"
+PACKAGECONFIG[drm] = "--enable-drm,,libdrm"
PACKAGECONFIG[drm-lease] = "--enable-drm-lease,,drm-lease-manager"
-PSPLASH_DRM_LEASE_ARGS ??= "--drm-lease lease0"
-PSPLASH_ARGS += "${@bb.utils.contains('PACKAGECONFIG', 'drm-lease', '${PSPLASH_DRM_LEASE_ARGS}', '', d)}"
-RDEPENDS:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'drm-lease', 'drm-lease-manager', '', d)}"
do_install:append () {
- sed -i -e "s!^\(ExecStart=/usr/bin/psplash.*\)!\1 ${PSPLASH_ARGS}!" ${D}${systemd_system_unitdir}/psplash-start.service
+ # Install override
+ install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
+ install -m 0644 ${WORKDIR}/psplash-drmlease.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}