summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/README.md
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-06-06 17:06:54 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-06-12 11:10:26 +0000
commit83bbf82c41de1d532a920fa42326c17f40ea172f (patch)
treefaadb04910185130d74f367cbb9407c77f7993c8 /meta-agl-flutter/README.md
parent0ccbb175eb5efdb59d0231198b295a21e3c466db (diff)
meta-agl-flutter: update for meta-agl-core changes
Changes: - Pull in image .bb files instead of .inc files. - Use agl-image-compositor as the base image for agl-image-flutter. instead of the appending done to agl-image-weston and its packagegroup previously. - Rework flutter-gallery systemd unit to work again, and update our bbappend to install it as disabled as an option for starting up flutter-gallery in agl-image-flutter. It seems useful to keep it present to serve as an example of starting Flutter apps via systemd and using the agl-flutter-env package. - Some minor documentation updates in README.md. - Replace some :append usage with += to avoid creating problems for downstream users. Bug-AGL: SPEC-4813 Change-Id: I8a61d6365ce69ac50b88abc7bc451486b3e1b339 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-flutter/README.md')
-rw-r--r--meta-agl-flutter/README.md10
1 files changed, 4 insertions, 6 deletions
diff --git a/meta-agl-flutter/README.md b/meta-agl-flutter/README.md
index 84bbf260..ba017d15 100644
--- a/meta-agl-flutter/README.md
+++ b/meta-agl-flutter/README.md
@@ -1,14 +1,14 @@
# meta-agl-flutter
-## Steps to build `agl-demo-platform` image
+## Steps to build `agl-ivi-demo-platform-flutter` image
```
export AGL_TOP=$HOME/workspace_agl
mkdir -p $AGL_TOP && cd $AGL_TOP
repo init -u https://gerrit.automotivelinux.org/gerrit/AGL/AGL-repo -b master
repo sync -j $(nproc)
- source meta-agl/scripts/aglsetup.sh -m qemux86-64 agl-demo agl-flutter
- bitbake agl-demo-platform
+ source meta-agl/scripts/aglsetup.sh -m qemux86-64 agl-demo
+ bitbake agl-ivi-demo-platform-flutter
```
This builds AGL demo image that includes Flutter runtime={debug,profile,release}.
@@ -57,9 +57,7 @@ Additional documentation available [here](https://github.com/meta-flutter/meta-f
## Startup Service
-If you include `flutter-gallery-init` it will install a systemd user service, which starts the Flutter Gallery on boot. This is not included in the minimal images.
-
-At runtime you can edit `/usr/share/flutter/default.json` to point to any Flutter bundle.
+This layer includes an example systemd user service for the Flutter Gallery application which is disabled by default. It can be used to start the application in the minimal image by doing 'systemctl start flutter-gallery'.
## `/usr/share/flutter/default.json`