summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-06-06 17:06:54 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-06-12 11:10:26 +0000
commit83bbf82c41de1d532a920fa42326c17f40ea172f (patch)
treefaadb04910185130d74f367cbb9407c77f7993c8 /meta-agl-flutter/recipes-graphics
parent0ccbb175eb5efdb59d0231198b295a21e3c466db (diff)
meta-agl-flutter: update for meta-agl-core changes
Changes: - Pull in image .bb files instead of .inc files. - Use agl-image-compositor as the base image for agl-image-flutter. instead of the appending done to agl-image-weston and its packagegroup previously. - Rework flutter-gallery systemd unit to work again, and update our bbappend to install it as disabled as an option for starting up flutter-gallery in agl-image-flutter. It seems useful to keep it present to serve as an example of starting Flutter apps via systemd and using the agl-flutter-env package. - Some minor documentation updates in README.md. - Replace some :append usage with += to avoid creating problems for downstream users. Bug-AGL: SPEC-4813 Change-Id: I8a61d6365ce69ac50b88abc7bc451486b3e1b339 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-flutter/recipes-graphics')
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service9
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery_aglflutter.inc28
2 files changed, 15 insertions, 22 deletions
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
index 3d4ecbf1..80e31dda 100644
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
+++ b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
@@ -3,8 +3,11 @@ Requires=agl-compositor.service
After=agl-compositor.service
[Service]
-ExecStart=/usr/bin/flutter-auto --j=/usr/share/flutter/default.json --b=/usr/share/flutter/gallery --f
-Restart=on-failure
+User=agl-driver
+EnvironmentFile=/etc/default/flutter
+EnvironmentFile=-/etc/default/flutter-gallery
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
+ExecStart=/usr/bin/flutter-auto --b=/usr/share/flutter/gallery/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --f --window-type=BG
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery_aglflutter.inc b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery_aglflutter.inc
index c618a2fe..61bcaa0e 100644
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery_aglflutter.inc
+++ b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery_aglflutter.inc
@@ -1,28 +1,18 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/flutter-gallery:"
-SRC_URI += " \
- file://flutter-gallery.service \
-"
+SRC_URI += "file://flutter-gallery.service"
-# To avoid conflicts with the systemd template scheme added via bbappend in
-# meta-agl-demo, package the standalone systemd unit separately. This is not
-# needed when meta-agl-flutter is used without meta-agl-demo, but that is not
-# going to be the default usecase for most users, so this still allows them to
-# build working agl-image-flutter images in the same build tree.
-#
-# This can be dropped if/when flutter-gallery is no longer packaged as a demo
-# in meta-agl-demo.
-
-#SYSTEMD_SERVICE:${PN}-init = "flutter-gallery.service"
+inherit systemd
do_install:append() {
- install -D -m 0644 ${WORKDIR}/flutter-gallery.service ${D}${systemd_user_unitdir}/flutter-gallery.service
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- ln -s ../flutter-gallery.service ${D}${systemd_user_unitdir}/agl-session.target.wants/flutter-gallery.service
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
-PACKAGE_BEFORE_PN += "${PN}-init"
+#FILES:${PN} += "${systemd_system_unitdir}"
-FILES:${PN}-init = "${systemd_user_unitdir}"
+RDEPENDS:${PN} += "agl-flutter-env"
-RDEPENDS:${PN}-init = "${PN}" \ No newline at end of file
+SYSTEMD_SERVICE:${PN} = "flutter-gallery.service"
+# Explicitly disable auto-start to avoid interferring with Toyota workspace
+# tooling usecase.
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"