summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/recipes-graphics
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2022-09-06 17:02:55 -0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-12 09:47:58 +0000
commitee6873ad9024399cc69f81bab2745eb3a0bb3649 (patch)
treebe77508b3d89e6d2dd83135b86a5b86beaf15761 /meta-agl-flutter/recipes-graphics
parent0457026fc28c1914d4e12a444c61f1a25ca257dd (diff)
meta-agl-flutter updates
-layer README -flutter workspace configuration file -consolidation of gallery json files -remove flutter sdk version pin; now happens upstream -add engine_sdk.zip to all images (non-production) -add SSH server to debug and profile images -factor out flutter-auto xdg-shell-app-id patch Signed-off-by: Joel Winarske <joel.winarske@gmail.com> Change-Id: I6fdf1277bb4011126103f74eda5e230f34f497d7
Diffstat (limited to 'meta-agl-flutter/recipes-graphics')
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service2
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-debug.json11
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-profile.json11
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-release.json10
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery_aglflutter.inc11
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-engine/flutter-engine_git.bbappend1
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/files/0001-Add-xdg-shell-app-id-command-line-argument.patch38
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc8
8 files changed, 1 insertions, 91 deletions
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
index 71ab791d..3d4ecbf1 100644
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
+++ b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
@@ -3,7 +3,7 @@ Requires=agl-compositor.service
After=agl-compositor.service
[Service]
-ExecStart=/usr/bin/flutter-auto --j=/usr/share/flutter/default.json
+ExecStart=/usr/bin/flutter-auto --j=/usr/share/flutter/default.json --b=/usr/share/flutter/gallery --f
Restart=on-failure
[Install]
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-debug.json b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-debug.json
deleted file mode 100644
index 5a84a0bd..00000000
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-debug.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/gallery",
- "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234"],
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-profile.json b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-profile.json
deleted file mode 100644
index 3309fde4..00000000
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-profile.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/gallery",
- "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234", "--start-paused"],
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-release.json b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-release.json
deleted file mode 100644
index 6a2a8448..00000000
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/gallery_on_bg-release.json
+++ /dev/null
@@ -1,10 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/gallery",
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery_aglflutter.inc b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery_aglflutter.inc
index 533bdd71..c618a2fe 100644
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery_aglflutter.inc
+++ b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery_aglflutter.inc
@@ -2,15 +2,8 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/flutter-gallery:"
SRC_URI += " \
file://flutter-gallery.service \
- file://gallery_on_bg-debug.json \
- file://gallery_on_bg-profile.json \
- file://gallery_on_bg-release.json \
"
-APP_CONFIG = "gallery_on_bg-release.json"
-APP_CONFIG:class-runtimedebug = "gallery_on_bg-debug.json"
-APP_CONFIG:class-runtimeprofile = "gallery_on_bg-profile.json"
-
# To avoid conflicts with the systemd template scheme added via bbappend in
# meta-agl-demo, package the standalone systemd unit separately. This is not
# needed when meta-agl-flutter is used without meta-agl-demo, but that is not
@@ -26,14 +19,10 @@ do_install:append() {
install -D -m 0644 ${WORKDIR}/flutter-gallery.service ${D}${systemd_user_unitdir}/flutter-gallery.service
install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
ln -s ../flutter-gallery.service ${D}${systemd_user_unitdir}/agl-session.target.wants/flutter-gallery.service
-
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/default.json
}
PACKAGE_BEFORE_PN += "${PN}-init"
-FILES:${PN} += "${datadir}"
-
FILES:${PN}-init = "${systemd_user_unitdir}"
RDEPENDS:${PN}-init = "${PN}" \ No newline at end of file
diff --git a/meta-agl-flutter/recipes-graphics/flutter-engine/flutter-engine_git.bbappend b/meta-agl-flutter/recipes-graphics/flutter-engine/flutter-engine_git.bbappend
deleted file mode 100644
index b3ca883f..00000000
--- a/meta-agl-flutter/recipes-graphics/flutter-engine/flutter-engine_git.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-do_install[network] = "1"
diff --git a/meta-agl-flutter/recipes-graphics/toyota/files/0001-Add-xdg-shell-app-id-command-line-argument.patch b/meta-agl-flutter/recipes-graphics/toyota/files/0001-Add-xdg-shell-app-id-command-line-argument.patch
deleted file mode 100644
index 854c8dc8..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/files/0001-Add-xdg-shell-app-id-command-line-argument.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 394f48a1e535f464879fa94196ee6d73b86894f5 Mon Sep 17 00:00:00 2001
-From: Scott Murray <scott.murray@konsulko.com>
-Date: Thu, 4 Aug 2022 14:36:08 -0400
-Subject: [PATCH] Add xdg-shell-app-id command-line argument
-
-Add a command-line argument for specifying the app id, so that basic
-applications do not need to supply a full JSON configuration just to
-do so.
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
----
- shell/main.cc | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
-diff --git a/shell/main.cc b/shell/main.cc
-index deb4876..ba35acc 100644
---- a/shell/main.cc
-+++ b/shell/main.cc
-@@ -161,6 +161,16 @@ int main(int argc, char** argv) {
- FML_DLOG(INFO) << "Window Type: " << config.view.window_type;
- RemoveArgument(config.view.vm_args, "--window-type=" + config.view.window_type);
- }
-+ if (cl.HasOption("xdg-shell-app-id")) {
-+ cl.GetOptionValue("xdg-shell-app-id", &config.app_id);
-+ if (config.app_id.empty()) {
-+ FML_LOG(ERROR)
-+ << "--xdg-shell-app-id option requires an argument (e.g. --xdg-shell-app-id=gallery)";
-+ return EXIT_FAILURE;
-+ }
-+ FML_DLOG(INFO) << "Application ID: " << config.app_id;
-+ RemoveArgument(config.view.vm_args, "--xdg-shell-app-id=" + config.app_id);
-+ }
- }
-
- auto vm_arg_count = config.view.vm_args.size();
---
-2.35.3
-
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc
index 0b580c2a..1fb1a3b4 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc
+++ b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc
@@ -1,12 +1,4 @@
-FILESEXTRAPATHS:append := "${THISDIR}/files:"
-
-SRC_URI += " \
- file://0001-Add-xdg-shell-app-id-command-line-argument.patch \
-"
# For now disable gstreamer to avoid needing to enable "commercial"
# licenses for the stated ffmpeg dependency.
PACKAGECONFIG:remove = "gstreamer"
-
-# Enable verbose logging on runtimedebug image
-PACKAGECONFIG:append:runtimedebug = "verbose"