summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/recipes-platform
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2022-08-03 18:19:31 -0700
committerJoel Winarske <joel.winarske@gmail.com>2022-08-03 18:19:31 -0700
commitadbb12626100901bc815deba27733fe1a3ebc3cc (patch)
tree6f70ed31f427b342689b1d7785ac9ae7e5bdc0e8 /meta-agl-flutter/recipes-platform
parent9a4f63a3bc70b11bd070989b95ddca2c11920a57 (diff)
meta-agl-flutter refactor
- application rename -> flutter-auto - adopts upstream (meta-flutter) bbclass for runtime selection runtimedebug -> runtime=debug runtimeprofile -> runtime=profile runtimerelease -> runtime=release *This also affects image names* - A discrete json files for each runtime configuration demuxing of runtime config happens in bbappend. - prevent dev host conflict with flutter-auto.service in case of debug and profile. The dev host machine controls homescreen in these scenarios. - simplifies inc and recipes Dependent on https://gerrit.automotivelinux.org/gerrit/c/AGL/AGL-repo/+/27850 Bug-AGL: SPEC-4326 Signed-off-by: Joel Winarske <joel.winarske@gmail.com> Change-Id: I877811417e3befab4d48a906058dcb52c81be4ce
Diffstat (limited to 'meta-agl-flutter/recipes-platform')
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb20
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-profile.bb20
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimedebug.bb21
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimeprofile.bb19
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimerelease.bb19
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb20
6 files changed, 59 insertions, 60 deletions
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
deleted file mode 100644
index 2c24699b..00000000
--- a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "Baseline Flutter Image for Development"
-
-LICENSE = "MIT"
-
-require agl-image-flutter.inc
-
-IMAGE_INSTALL:append = "\
- weston-ini-conf-landscape \
- \
- ivi-homescreen-debug \
- flutter-engine-debug \
- \
- flutter-gallery-debug \
- flutter-test-secure-storage-debug \
- flutter-test-texture-egl-debug \
- flutter-test-video-player-debug \
- \
- flutter-app-igalia-homescreen-debug \
- flutter-app-pumped-fuel-ped-debug \
- "
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-profile.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-profile.bb
deleted file mode 100644
index 33ae39c9..00000000
--- a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-profile.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "Baseline Flutter Image for Profiling"
-
-LICENSE = "MIT"
-
-require agl-image-flutter.inc
-
-IMAGE_INSTALL:append = "\
- weston-ini-conf-landscape \
- \
- ivi-homescreen-profile \
- flutter-engine-profile \
- \
- flutter-gallery-profile \
- flutter-test-secure-storage-profile \
- flutter-test-texture-egl-profile \
- flutter-test-video-player-profile \
- \
- flutter-app-igalia-homescreen-profile \
- flutter-app-pumped-fuel-ped-profile \
- "
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimedebug.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimedebug.bb
new file mode 100644
index 00000000..6c412597
--- /dev/null
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimedebug.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Baseline Flutter Image for Development"
+
+LICENSE = "MIT"
+
+require agl-image-flutter.inc
+
+IMAGE_INSTALL:append = "\
+ weston-ini-conf-landscape \
+ \
+ flutter-auto-runtimedebug \
+ \
+ flutter-engine-runtimedebug-sdk-dev \
+ \
+ flutter-gallery-runtimedebug \
+ flutter-test-texture-egl-runtimedebug \
+ flutter-test-secure-storage-runtimedebug \
+ flutter-test-localization-runtimedebug \
+ \
+ flutter-app-igalia-homescreen-runtimedebug \
+ flutter-app-pumped-fuel-ped-runtimedebug \
+ "
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimeprofile.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimeprofile.bb
new file mode 100644
index 00000000..a69302b3
--- /dev/null
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimeprofile.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Baseline Flutter Image for Profiling"
+
+LICENSE = "MIT"
+
+require agl-image-flutter.inc
+
+IMAGE_INSTALL:append = "\
+ weston-ini-conf-landscape \
+ \
+ flutter-auto-runtimeprofile \
+ \
+ flutter-gallery-runtimeprofile \
+ flutter-test-texture-egl-runtimeprofile \
+ flutter-test-secure-storage-runtimeprofile \
+ flutter-test-localization-runtimeprofile \
+ \
+ flutter-app-igalia-homescreen-runtimeprofile \
+ flutter-app-pumped-fuel-ped-runtimeprofile \
+ "
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimerelease.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimerelease.bb
new file mode 100644
index 00000000..cf60e8be
--- /dev/null
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-runtimerelease.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Baseline Flutter Image for Release"
+
+LICENSE = "MIT"
+
+require agl-image-flutter.inc
+
+IMAGE_INSTALL:append = "\
+ weston-ini-conf-landscape \
+ \
+ flutter-auto-runtimerelease \
+ \
+ flutter-gallery-runtimerelease \
+ flutter-test-texture-egl-runtimerelease \
+ flutter-test-secure-storage-runtimerelease \
+ flutter-test-localization-runtimerelease \
+ \
+ flutter-app-igalia-homescreen-runtimerelease \
+ flutter-app-pumped-fuel-ped-runtimerelease \
+ "
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
deleted file mode 100644
index 83809426..00000000
--- a/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "Baseline Flutter Image for Release"
-
-LICENSE = "MIT"
-
-require agl-image-flutter.inc
-
-IMAGE_INSTALL:append = "\
- weston-ini-conf-landscape \
- \
- ivi-homescreen-release \
- flutter-engine-release \
- \
- flutter-gallery-release \
- flutter-test-secure-storage-release \
- flutter-test-texture-egl-release \
- flutter-test-video-player-release \
- \
- flutter-app-igalia-homescreen-flutterrelease \
- flutter-app-pumped-fuel-ped-flutterrelease \
- "