summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2022-05-12 11:54:48 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-12 11:12:58 +0000
commit9e91874e6e23eb36570653aaf93e0d4d994d90bc (patch)
tree3fa06f17e643adf2e50981fb233740409d83ef98 /meta-agl-flutter
parentcab8ffa1594bd44df835500dd5498e45052f81ff (diff)
flutter-gallery: Add network access workaround
This is a temporary work-around to have a flutter-gallery bbapend until external/meta-flutter is synced-up to include this fix. It allows flutter sdk to be able to download whatever dependencies it needs to build the gallery application. Bug-AGL: SPEC-4371 Suggested-by: Scott Murray <scott.murray@konsulko.com> Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I676d5d2f5b8b5977bb7b4d745b94cfb53459ac8e
Diffstat (limited to 'meta-agl-flutter')
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-debug_%.bbappend1
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-profile_%.bbappend1
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-release_%.bbappend1
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-gallery_aglflutter.inc1
4 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-debug_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-debug_%.bbappend
new file mode 100644
index 00000000..835e86e6
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-debug_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'flutter-gallery_aglflutter.inc', '', d)}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-profile_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-profile_%.bbappend
new file mode 100644
index 00000000..835e86e6
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-profile_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'flutter-gallery_aglflutter.inc', '', d)}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-release_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-release_%.bbappend
new file mode 100644
index 00000000..835e86e6
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-release_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'flutter-gallery_aglflutter.inc', '', d)}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery_aglflutter.inc
new file mode 100644
index 00000000..ef03af27
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery_aglflutter.inc
@@ -0,0 +1 @@
+do_compile[network] = "1"