summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/dynamic-layers
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2023-05-12 00:16:58 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2023-05-12 01:02:19 +0900
commite394dc88e3acc56bde094ccfa044da23998491db (patch)
tree20dbd7568b5624438303f35b58060e7032124494 /meta-agl-ic-container/dynamic-layers
parent524be1d47688e8053457b1037b059414efa3032c (diff)
Move configuration files to subdirectory for raspberrypi4
In https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-devel/+/28799, I got a review comment for place of configuration files. This patch fix place of configuration files for raspberry pi 4. Bug-AGL : SPEC-4790 Change-Id: I6d2acc2a4f611dd68d34146a40d93abb4e0eed51 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'meta-agl-ic-container/dynamic-layers')
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-flutter-ivi-demo/agl-flutter-ivi-demo.json166
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-flutter-ivi-demo_%.bbappend2
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-html5-ivi-demo/agl-html5-ivi-demo.json167
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-html5-ivi-demo_%.bbappend2
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-momi-ivi-demo/agl-momi-ivi-demo.json167
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-momi-ivi-demo_%.bbappend2
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-qt-ivi-demo/agl-qt-ivi-demo.json167
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-qt-ivi-demo_%.bbappend2
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-cluster-demo/cluster-demo.json95
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-cluster-demo_%.bbappend7
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-graphics/drm-lease-manager/drm-lease-manager-init.bbappend2
-rw-r--r--meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-graphics/drm-lease-manager/drm-lease-manager-init/drm-lease-manager.ini7
12 files changed, 0 insertions, 786 deletions
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-flutter-ivi-demo/agl-flutter-ivi-demo.json b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-flutter-ivi-demo/agl-flutter-ivi-demo.json
deleted file mode 100644
index 4393703b..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-flutter-ivi-demo/agl-flutter-ivi-demo.json
+++ /dev/null
@@ -1,166 +0,0 @@
-{
- "name": "agl-flutter-ivi-demo",
- "role": "ivi",
- "base": {
- "autoboot": false,
- "bootpriority": 10,
- "rootfs": {
- "path": "/opt/container/guests/agl-flutter-ivi-demo/rootfs",
- "filesystem": "ext4",
- "mode": "rw",
- "blockdev": [
- "/dev/mmcblk0p7",
- "/dev/mmcblk0p7"
- ]
- },
- "lifecycle": {
- "halt": "SIGRTMIN+3",
- "reboot": "SIGTERM"
- },
- "cap": {
- "drop": "sys_module mac_admin mac_override",
- "keep": ""
- },
- "environment": [
- "PIPEWIRE_RUNTIME_DIR=/var",
- "HOME=/home/root"
- ]
- },
- "fs": {
- "mount": [
- {
- "type": "filesystem",
- "from": "tmpfs",
- "to": "run",
- "fstype": "tmpfs",
- "option": "defaults 0 0"
- },
- {
- "type": "directory",
- "from": "/sys/kernel/security",
- "to": "sys/kernel/security",
- "fstype": "none",
- "option": "ro,bind,optional 0 0"
- },
- {
- "type": "directory",
- "from": "/run/udev/data",
- "to": "run/udev/data",
- "fstype": "none",
- "option": "ro,bind,optional,create=dir"
- },
- {
- "type": "directory",
- "from": "/run/drm-lease-manager/lease-ivi",
- "to": "var/display/drm-lease-manager/lease",
- "fstype": "none",
- "option": "bind,create=file"
- },
- {
- "type": "directory",
- "from": "/run/pipewire/pipewire-0",
- "to": "var/pipewire-0",
- "fstype": "none",
- "option": "bind,optional,create=file"
- },
- {
- "type": "directory",
- "from": "/opt/container/guests/agl-flutter-ivi-demo/system.conf",
- "to": "etc/systemd/system.conf.d/10-environment.conf",
- "fstype": "none",
- "option": "bind,optional,create=file"
- }
- ]
- },
- "device": {
- "static": [
- {
- "type": "devdir",
- "from": "/dev/dri",
- "to": "dev/dri",
- "devnode": "/dev/dri/card0",
- "optional": 0,
- "wideallow": 1,
- "exclusive": 0
- },
- {
- "type": "devdir",
- "from": "/dev/input",
- "to": "dev/input",
- "devnode": "/dev/input/event0",
- "optional": 1,
- "wideallow": 1,
- "exclusive": 0
- }
- ],
- "dynamic": [
- {
- "devpath": "/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/",
- "items": [
- {
- "subsystem": "usb",
- "rule": {
- "devtype": ["usb_device","usb_interface"],
- "action": ["add", "remove"]
- },
- "behavior": {
- "injection": 1,
- "devnode": 0,
- "allow": 0,
- "permission": "rw"
- }
- },
- {
- "subsystem": "block",
- "rule": {
- "action": ["add", "remove","change"],
- "extra" : [
- {
- "checker": "exclude-fs",
- "value": "ext4"
- }
- ]
- },
- "behavior": {
- "injection": 1,
- "devnode": 0,
- "allow": 1,
- "permission": "rwm"
- }
- }
- ]
- },
- {
- "devpath": "/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/",
- "items": [
- {
- "subsystem": "hid",
- "rule": {
- "action": ["add", "remove"]
- },
- "behavior": {
- "injection": 1,
- "devnode": 1,
- "allow": 1,
- "permission": "rw"
- }
- }
- ]
- }
- ]
- },
- "network": {
- "static": [
- {
- "type": "veth",
- "param": {
- "name": "veth0",
- "link": "lxcbr0",
- "flags": "up",
- "hwaddr": "00:16:3e:xx:xx:xx",
- "mode": "bridge"
- }
- }
- ]
- }
-}
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-flutter-ivi-demo_%.bbappend b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-flutter-ivi-demo_%.bbappend
deleted file mode 100644
index bd73278b..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-flutter-ivi-demo_%.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-# Container Manager config for AGL flutter IVI demo on R-Car Gen3
-FILESEXTRAPATHS:prepend := "${THISDIR}/cm-config-agl-flutter-ivi-demo:"
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-html5-ivi-demo/agl-html5-ivi-demo.json b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-html5-ivi-demo/agl-html5-ivi-demo.json
deleted file mode 100644
index a569bcf5..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-html5-ivi-demo/agl-html5-ivi-demo.json
+++ /dev/null
@@ -1,167 +0,0 @@
-{
- "name": "agl-html5-ivi-demo",
- "role": "ivi",
- "base": {
- "autoboot": false,
- "bootpriority": 10,
- "rootfs": {
- "path": "/opt/container/guests/agl-html5-ivi-demo/rootfs",
- "filesystem": "ext4",
- "mode": "rw",
- "blockdev": [
- "/dev/mmcblk0p8",
- "/dev/mmcblk0p8"
- ]
- },
- "lifecycle": {
- "halt": "SIGRTMIN+3",
- "reboot": "SIGTERM",
- "timeout": 15000
- },
- "cap": {
- "drop": "sys_module mac_admin mac_override",
- "keep": ""
- },
- "environment": [
- "PIPEWIRE_RUNTIME_DIR=/var",
- "HOME=/home/root"
- ]
- },
- "fs": {
- "mount": [
- {
- "type": "filesystem",
- "from": "tmpfs",
- "to": "run",
- "fstype": "tmpfs",
- "option": "defaults 0 0"
- },
- {
- "type": "directory",
- "from": "/sys/kernel/security",
- "to": "sys/kernel/security",
- "fstype": "none",
- "option": "ro,bind,optional 0 0"
- },
- {
- "type": "directory",
- "from": "/run/udev/data",
- "to": "run/udev/data",
- "fstype": "none",
- "option": "ro,bind,optional,create=dir"
- },
- {
- "type": "directory",
- "from": "/run/drm-lease-manager/lease-ivi",
- "to": "var/display/drm-lease-manager/lease",
- "fstype": "none",
- "option": "bind,create=file"
- },
- {
- "type": "directory",
- "from": "/run/pipewire/pipewire-0",
- "to": "var/pipewire-0",
- "fstype": "none",
- "option": "bind,optional,create=file"
- },
- {
- "type": "directory",
- "from": "/opt/container/guests/agl-html5-ivi-demo/system.conf",
- "to": "etc/systemd/system.conf.d/10-environment.conf",
- "fstype": "none",
- "option": "bind,optional,create=file"
- }
- ]
- },
- "device": {
- "static": [
- {
- "type": "devdir",
- "from": "/dev/dri",
- "to": "dev/dri",
- "devnode": "/dev/dri/card0",
- "optional": 0,
- "wideallow": 1,
- "exclusive": 0
- },
- {
- "type": "devdir",
- "from": "/dev/input",
- "to": "dev/input",
- "devnode": "/dev/input/event0",
- "optional": 1,
- "wideallow": 1,
- "exclusive": 0
- }
- ],
- "dynamic": [
- {
- "devpath": "/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/",
- "items": [
- {
- "subsystem": "usb",
- "rule": {
- "devtype": ["usb_device","usb_interface"],
- "action": ["add", "remove"]
- },
- "behavior": {
- "injection": 1,
- "devnode": 0,
- "allow": 0,
- "permission": "rw"
- }
- },
- {
- "subsystem": "block",
- "rule": {
- "action": ["add", "remove","change"],
- "extra" : [
- {
- "checker": "exclude-fs",
- "value": "ext4"
- }
- ]
- },
- "behavior": {
- "injection": 1,
- "devnode": 0,
- "allow": 1,
- "permission": "rwm"
- }
- }
- ]
- },
- {
- "devpath": "/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/",
- "items": [
- {
- "subsystem": "hid",
- "rule": {
- "action": ["add", "remove"]
- },
- "behavior": {
- "injection": 1,
- "devnode": 1,
- "allow": 1,
- "permission": "rw"
- }
- }
- ]
- }
- ]
- },
- "network": {
- "static": [
- {
- "type": "veth",
- "param": {
- "name": "veth0",
- "link": "lxcbr0",
- "flags": "up",
- "hwaddr": "00:16:3e:xx:xx:xx",
- "mode": "bridge"
- }
- }
- ]
- }
-}
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-html5-ivi-demo_%.bbappend b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-html5-ivi-demo_%.bbappend
deleted file mode 100644
index e810a7f0..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-html5-ivi-demo_%.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-# Container Manager config for AGL HTML5 IVI demo on R-Car Gen3
-FILESEXTRAPATHS:prepend := "${THISDIR}/cm-config-agl-html5-ivi-demo:"
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-momi-ivi-demo/agl-momi-ivi-demo.json b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-momi-ivi-demo/agl-momi-ivi-demo.json
deleted file mode 100644
index 24e02758..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-momi-ivi-demo/agl-momi-ivi-demo.json
+++ /dev/null
@@ -1,167 +0,0 @@
-{
- "name": "agl-momi-ivi-demo",
- "role": "ivi",
- "base": {
- "autoboot": true,
- "bootpriority": 10,
- "rootfs": {
- "path": "/opt/container/guests/agl-momi-ivi-demo/rootfs",
- "filesystem": "ext4",
- "mode": "rw",
- "blockdev": [
- "/dev/mmcblk0p5",
- "/dev/mmcblk0p5"
- ]
- },
- "lifecycle": {
- "halt": "SIGRTMIN+3",
- "reboot": "SIGTERM",
- "timeout": 15000
- },
- "cap": {
- "drop": "sys_module mac_admin mac_override",
- "keep": ""
- },
- "environment": [
- "PIPEWIRE_RUNTIME_DIR=/var",
- "HOME=/home/root"
- ]
- },
- "fs": {
- "mount": [
- {
- "type": "filesystem",
- "from": "tmpfs",
- "to": "run",
- "fstype": "tmpfs",
- "option": "defaults 0 0"
- },
- {
- "type": "directory",
- "from": "/sys/kernel/security",
- "to": "sys/kernel/security",
- "fstype": "none",
- "option": "ro,bind,optional 0 0"
- },
- {
- "type": "directory",
- "from": "/run/udev/data",
- "to": "run/udev/data",
- "fstype": "none",
- "option": "ro,bind,optional,create=dir"
- },
- {
- "type": "directory",
- "from": "/run/drm-lease-manager/lease-ivi",
- "to": "var/display/drm-lease-manager/lease",
- "fstype": "none",
- "option": "bind,create=file"
- },
- {
- "type": "directory",
- "from": "/run/pipewire/pipewire-0",
- "to": "var/pipewire-0",
- "fstype": "none",
- "option": "bind,optional,create=file"
- },
- {
- "type": "directory",
- "from": "/opt/container/guests/agl-momi-ivi-demo/system.conf",
- "to": "etc/systemd/system.conf.d/10-environment.conf",
- "fstype": "none",
- "option": "bind,optional,create=file"
- }
- ]
- },
- "device": {
- "static": [
- {
- "type": "devdir",
- "from": "/dev/dri",
- "to": "dev/dri",
- "devnode": "/dev/dri/card0",
- "optional": 0,
- "wideallow": 1,
- "exclusive": 0
- },
- {
- "type": "devdir",
- "from": "/dev/input",
- "to": "dev/input",
- "devnode": "/dev/input/event0",
- "optional": 1,
- "wideallow": 1,
- "exclusive": 0
- }
- ],
- "dynamic": [
- {
- "devpath": "/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/",
- "items": [
- {
- "subsystem": "usb",
- "rule": {
- "devtype": ["usb_device","usb_interface"],
- "action": ["add", "remove"]
- },
- "behavior": {
- "injection": 1,
- "devnode": 0,
- "allow": 0,
- "permission": "rw"
- }
- },
- {
- "subsystem": "block",
- "rule": {
- "action": ["add", "remove","change"],
- "extra" : [
- {
- "checker": "exclude-fs",
- "value": "ext4"
- }
- ]
- },
- "behavior": {
- "injection": 1,
- "devnode": 0,
- "allow": 1,
- "permission": "rwm"
- }
- }
- ]
- },
- {
- "devpath": "/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/",
- "items": [
- {
- "subsystem": "hid",
- "rule": {
- "action": ["add", "remove"]
- },
- "behavior": {
- "injection": 1,
- "devnode": 1,
- "allow": 1,
- "permission": "rw"
- }
- }
- ]
- }
- ]
- },
- "network": {
- "static": [
- {
- "type": "veth",
- "param": {
- "name": "eth0",
- "link": "lxcbr0",
- "flags": "up",
- "hwaddr": "00:16:3e:xx:xx:xx",
- "mode": "bridge"
- }
- }
- ]
- }
-}
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-momi-ivi-demo_%.bbappend b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-momi-ivi-demo_%.bbappend
deleted file mode 100644
index 8f229830..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-momi-ivi-demo_%.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-# Container Manager config for AGL Momi IVI demo on R-Car Gen3
-FILESEXTRAPATHS:prepend := "${THISDIR}/cm-config-agl-momi-ivi-demo:"
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-qt-ivi-demo/agl-qt-ivi-demo.json b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-qt-ivi-demo/agl-qt-ivi-demo.json
deleted file mode 100644
index 62ccbc14..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-qt-ivi-demo/agl-qt-ivi-demo.json
+++ /dev/null
@@ -1,167 +0,0 @@
-{
- "name": "agl-qt-ivi-demo",
- "role": "ivi",
- "base": {
- "autoboot": false,
- "bootpriority": 10,
- "rootfs": {
- "path": "/opt/container/guests/agl-qt-ivi-demo/rootfs",
- "filesystem": "ext4",
- "mode": "rw",
- "blockdev": [
- "/dev/mmcblk0p6",
- "/dev/mmcblk0p6"
- ]
- },
- "lifecycle": {
- "halt": "SIGRTMIN+3",
- "reboot": "SIGTERM",
- "timeout": 15000
- },
- "cap": {
- "drop": "sys_module mac_admin mac_override",
- "keep": ""
- },
- "environment": [
- "PIPEWIRE_RUNTIME_DIR=/var",
- "HOME=/home/root"
- ]
- },
- "fs": {
- "mount": [
- {
- "type": "filesystem",
- "from": "tmpfs",
- "to": "run",
- "fstype": "tmpfs",
- "option": "defaults 0 0"
- },
- {
- "type": "directory",
- "from": "/sys/kernel/security",
- "to": "sys/kernel/security",
- "fstype": "none",
- "option": "ro,bind,optional 0 0"
- },
- {
- "type": "directory",
- "from": "/run/udev/data",
- "to": "run/udev/data",
- "fstype": "none",
- "option": "ro,bind,optional,create=dir"
- },
- {
- "type": "directory",
- "from": "/run/drm-lease-manager/lease-ivi",
- "to": "var/display/drm-lease-manager/lease",
- "fstype": "none",
- "option": "bind,create=file"
- },
- {
- "type": "directory",
- "from": "/run/pipewire/pipewire-0",
- "to": "var/pipewire-0",
- "fstype": "none",
- "option": "bind,optional,create=file"
- },
- {
- "type": "directory",
- "from": "/opt/container/guests/agl-qt-ivi-demo/system.conf",
- "to": "etc/systemd/system.conf.d/10-environment.conf",
- "fstype": "none",
- "option": "bind,optional,create=file"
- }
- ]
- },
- "device": {
- "static": [
- {
- "type": "devdir",
- "from": "/dev/dri",
- "to": "dev/dri",
- "devnode": "/dev/dri/card0",
- "optional": 0,
- "wideallow": 1,
- "exclusive": 0
- },
- {
- "type": "devdir",
- "from": "/dev/input",
- "to": "dev/input",
- "devnode": "/dev/input/event0",
- "optional": 1,
- "wideallow": 1,
- "exclusive": 0
- }
- ],
- "dynamic": [
- {
- "devpath": "/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/",
- "items": [
- {
- "subsystem": "usb",
- "rule": {
- "devtype": ["usb_device","usb_interface"],
- "action": ["add", "remove"]
- },
- "behavior": {
- "injection": 1,
- "devnode": 0,
- "allow": 0,
- "permission": "rw"
- }
- },
- {
- "subsystem": "block",
- "rule": {
- "action": ["add", "remove","change"],
- "extra" : [
- {
- "checker": "exclude-fs",
- "value": "ext4"
- }
- ]
- },
- "behavior": {
- "injection": 1,
- "devnode": 0,
- "allow": 1,
- "permission": "rwm"
- }
- }
- ]
- },
- {
- "devpath": "/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/",
- "items": [
- {
- "subsystem": "hid",
- "rule": {
- "action": ["add", "remove"]
- },
- "behavior": {
- "injection": 1,
- "devnode": 1,
- "allow": 1,
- "permission": "rw"
- }
- }
- ]
- }
- ]
- },
- "network": {
- "static": [
- {
- "type": "veth",
- "param": {
- "name": "veth0",
- "link": "lxcbr0",
- "flags": "up",
- "hwaddr": "00:16:3e:xx:xx:xx",
- "mode": "bridge"
- }
- }
- ]
- }
-}
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-qt-ivi-demo_%.bbappend b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-qt-ivi-demo_%.bbappend
deleted file mode 100644
index 9c0ff8c2..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-agl-qt-ivi-demo_%.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-# Container Manager config for AGL Qt IVI demo on R-Car Gen3
-FILESEXTRAPATHS:prepend := "${THISDIR}/cm-config-agl-qt-ivi-demo:"
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-cluster-demo/cluster-demo.json b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-cluster-demo/cluster-demo.json
deleted file mode 100644
index 80f10cd6..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-cluster-demo/cluster-demo.json
+++ /dev/null
@@ -1,95 +0,0 @@
-{
- "name": "cluster-demo",
- "role": "cluster",
- "base": {
- "autoboot": true,
- "bootpriority": 1,
- "rootfs": {
- "path": "/opt/container/guests/cluster-demo/rootfs",
- "filesystem": "ext4",
- "mode": "rw",
- "blockdev": [
- "/dev/mmcblk0p3",
- "/dev/mmcblk0p3"
- ]
- },
- "lifecycle": {
- "halt": "SIGRTMIN+3",
- "reboot": "SIGTERM",
- "timeout": 5000
- },
- "cap": {
- "drop": "sys_module mac_admin mac_override sys_time",
- "keep": ""
- },
- "environment": [
- "HOME=/home/root"
- ]
- },
- "fs": {
- "mount": [
- {
- "type": "filesystem",
- "from": "tmpfs",
- "to": "run",
- "fstype": "tmpfs",
- "option": "defaults 0 0"
- },
- {
- "type": "directory",
- "from": "/sys/kernel/security",
- "to": "sys/kernel/security",
- "fstype": "none",
- "option": "ro,bind,optional 0 0"
- },
- {
- "type": "directory",
- "from": "/run/drm-lease-manager/lease-cluster",
- "to": "var/display/drm-lease-manager/lease",
- "fstype": "none",
- "option": "bind,create=file"
- },
- {
- "type": "directory",
- "from": "/run/pipewire/icipc-0",
- "to": "var/icipc-0",
- "fstype": "none",
- "option": "bind,optional,create=file"
- },
- {
- "type": "directory",
- "from": "/opt/container/guests/cluster-demo/system.conf",
- "to": "etc/systemd/system.conf.d/10-environment.conf",
- "fstype": "none",
- "option": "bind,optional,create=file"
- }
- ]
- },
- "device": {
- "static": [
- {
- "type": "devdir",
- "from": "/dev/dri",
- "to": "dev/dri",
- "devnode": "/dev/dri/card0",
- "optional": 0,
- "wideallow": 1,
- "exclusive": 0
- }
- ]
- },
- "network": {
- "static": [
- {
- "type": "veth",
- "param": {
- "name": "veth0",
- "link": "lxcbr0",
- "flags": "up",
- "hwaddr": "00:16:3e:xx:xx:xx",
- "mode": "bridge"
- }
- }
- ]
- }
-}
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-cluster-demo_%.bbappend b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-cluster-demo_%.bbappend
deleted file mode 100644
index 0a487ad8..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-container/container-manager-config/cm-config-cluster-demo_%.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
-# Container Manager config for cluster demo on R-Car Gen3
-FILESEXTRAPATHS:prepend := "${THISDIR}/cm-config-cluster-demo:"
-
-require conf/include/drm-lease-multi-display.inc
-
-# If you want to change display assign in your board, please change this line in your recipe.
-DRM_LEASE_DEVICE ?= "${@bb.utils.contains("HAS_MULTI_DISPLAY", "1", "card0-HDMI-A-2", "card0-HDMI-A-1" ,d)}"
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-graphics/drm-lease-manager/drm-lease-manager-init.bbappend b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-graphics/drm-lease-manager/drm-lease-manager-init.bbappend
deleted file mode 100644
index 371f6539..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-graphics/drm-lease-manager/drm-lease-manager-init.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI = "file://drm-lease-manager.ini"
diff --git a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-graphics/drm-lease-manager/drm-lease-manager-init/drm-lease-manager.ini b/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-graphics/drm-lease-manager/drm-lease-manager-init/drm-lease-manager.ini
deleted file mode 100644
index 45ecfc27..00000000
--- a/meta-agl-ic-container/dynamic-layers/meta-raspberrypi/recipes-graphics/drm-lease-manager/drm-lease-manager-init/drm-lease-manager.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[[lease]]
-name="lease-ivi"
-connectors=["HDMI-A-1"]
-
-[[lease]]
-name="lease-cluster"
-connectors=["HDMI-A-2"]