summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-container
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-01 15:04:53 -0400
committerScott Murray <scott.murray@konsulko.com>2024-05-01 15:04:53 -0400
commitb7b86b40da97986e310cfcbbb58aaddb3f972f09 (patch)
tree0f84427e8db8ec32c70831ec01a30d3a6d6a6f4c /meta-agl-ic-container/recipes-container
parent4de37d6af4cc5d98007f7904a783a61d19c14ea3 (diff)
meta-agl-ic-container: updates for scarthgap upgrade
Initial set of fixes to handle upgrade to YP 5.0 / scarthgap. The images are still not buildable after these changes due to the DRM lease changes to Weston needing further work. Changes: - Rename gstreamer1.0-plugins-bad bbappend for version bump. - Update rcar-gen3 kernel module bbappends to be compatible with upstream recipe changes. - Update lxc bbappend to handle addition of lxc-monitord in new version. - Refreshed wireplumber patch to fix QA errors. - Dropped dlt-daemon logging patch for now, IC EG will need to investigate whether it is still required. Bug-AGL: SPEC-5123 Change-Id: I3c49bee8c53ef5127950643d3f455167e4da30d9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-ic-container/recipes-container')
-rw-r--r--meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend b/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend
index cbfc6135..7ee8b6cf 100644
--- a/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend
+++ b/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend
@@ -16,12 +16,14 @@ do_install:append () {
}
# Divide lxc autostart from main package.
-SYSTEMD_PACKAGES = "${PN}-autostart ${PN}-networking"
+SYSTEMD_PACKAGES = "${PN}-autostart ${PN}-monitord ${PN}-networking"
SYSTEMD_SERVICE:${PN} = ""
SYSTEMD_SERVICE:${PN}-autostart = "lxc.service"
SYSTEMD_AUTO_ENABLE:${PN}-autostart = "enable"
+SYSTEMD_SERVICE:${PN}-monitord = "lxc-monitord.service"
+SYSTEMD_AUTO_ENABLE:${PN}-monitord = "enable"
-PACKAGES =+ "${PN}-autostart"
+PACKAGES =+ "${PN}-autostart ${PN}-monitord"
FILES:${PN}-autostart += " \
${sysconfdir}/default/lxc \
@@ -30,6 +32,9 @@ FILES:${PN}-autostart += " \
FILES:${PN}-doc += " \
${datadir}/doc/lxc/examples \
"
+FILES:${PN}-monitord += " \
+ ${libexexdir}/lxc/lxc-monitord \
+"
FILES:${PN}-networking += " \
${sysconfdir}/dnsmasq.d \
"