summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 11:33:17 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 15:45:17 +0200
commit68fa652a418a5dfcee12386fd58939bfd626144d (patch)
tree35db36536266979f085683985f5f0e5249df8e1f /meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb
parent17087e4083b2b6b070cec55c38288644689fa55c (diff)
Rename Instrument Cluster Container layerneedlefish_14.0.0needlefish/14.0.014.0.0
meta-agl-lxc is no longer reflecting the actual content and use of the layer. Rename it to 'meta-agl-ic-container' and the feature to 'agl-ic-container'. Also rename the main image to 'agl-cluster-demo-lxc-host' to match the pattern used by all other images e.g. agl-<ivi,cluster,telematics>-demo-* . But keep the names of the underlying images as-is. Bug-AGL: SPEC-4464 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I898c786ca884331b302a3be8e150379fcf5bdc9b
Diffstat (limited to 'meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb')
-rw-r--r--meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb b/meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb
new file mode 100644
index 00000000..0714f62b
--- /dev/null
+++ b/meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Systemd network interface configuration"
+DESCRIPTION = "Systemd network interface configuration \
+ "
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = " \
+ file://20-wired.network \
+ "
+
+do_install() {
+ install -D -m0644 ${WORKDIR}/20-wired.network ${D}${sysconfdir}/systemd/network/20-wired.network
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FILES:${PN} = "\
+ ${sysconfdir}/systemd/network/* \
+"