summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-core
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 11:33:17 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 15:43:04 +0200
commit13169c3265ba75d783eb3723504298a08e768110 (patch)
tree9f30b921d3491ad9bc8a55d58fd3bf6f3db8800e /meta-agl-ic-container/recipes-core
parentce87122d195d3a1fea454cfa4acd91e22ccea264 (diff)
Rename Instrument Cluster Container layer
meta-agl-lxc is no longer reflecting the actual content and use of the layer. Rename it to 'meta-agl-ic-container' and the feature to 'agl-ic-container'. Also rename the main image to 'agl-cluster-demo-lxc-host' to match the pattern used by all other images e.g. agl-<ivi,cluster,telematics>-demo-* . But keep the names of the underlying images as-is. Bug-AGL: SPEC-4464 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I898c786ca884331b302a3be8e150379fcf5bdc9b
Diffstat (limited to 'meta-agl-ic-container/recipes-core')
-rw-r--r--meta-agl-ic-container/recipes-core/base-files/base-files/fstab3
-rw-r--r--meta-agl-ic-container/recipes-core/base-files/base-files_%.bbappend2
-rw-r--r--meta-agl-ic-container/recipes-core/libclusterapi/libclusterapi_git.bb16
-rw-r--r--meta-agl-ic-container/recipes-core/libclusteripc/libclusteripc_git.bb14
-rw-r--r--meta-agl-ic-container/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend8
-rw-r--r--meta-agl-ic-container/recipes-core/systemd/systemd-netif-config/20-wired.network6
-rw-r--r--meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb19
7 files changed, 68 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-core/base-files/base-files/fstab b/meta-agl-ic-container/recipes-core/base-files/base-files/fstab
new file mode 100644
index 00000000..a27f8cd6
--- /dev/null
+++ b/meta-agl-ic-container/recipes-core/base-files/base-files/fstab
@@ -0,0 +1,3 @@
+# Reference fstab for container guest
+devpts /dev/pts devpts mode=0620,gid=5 0 0
+tmpfs /var/volatile tmpfs defaults 0 0
diff --git a/meta-agl-ic-container/recipes-core/base-files/base-files_%.bbappend b/meta-agl-ic-container/recipes-core/base-files/base-files_%.bbappend
new file mode 100644
index 00000000..2df9447b
--- /dev/null
+++ b/meta-agl-ic-container/recipes-core/base-files/base-files_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS:prepend:aglcontainerguest := "${THISDIR}/base-files:"
+
diff --git a/meta-agl-ic-container/recipes-core/libclusterapi/libclusterapi_git.bb b/meta-agl-ic-container/recipes-core/libclusterapi/libclusterapi_git.bb
new file mode 100644
index 00000000..af974e49
--- /dev/null
+++ b/meta-agl-ic-container/recipes-core/libclusterapi/libclusterapi_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "AGL Instrument Cluster API library"
+DESCRIPTION = "AGL Instrument Cluster API is defined common function API for Instrument Cluster.\
+ This library was contributed by four EG member company."
+HOMEPAGE = "https://confluence.automotivelinux.org/display/IC"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "libclusteripc"
+
+SRC_URI = "git://git.automotivelinux.org/src/libcluster-api;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "3ef96b9efb7c80f3f7a731379dcbfa9a21e2ceed"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
diff --git a/meta-agl-ic-container/recipes-core/libclusteripc/libclusteripc_git.bb b/meta-agl-ic-container/recipes-core/libclusteripc/libclusteripc_git.bb
new file mode 100644
index 00000000..c55906f8
--- /dev/null
+++ b/meta-agl-ic-container/recipes-core/libclusteripc/libclusteripc_git.bb
@@ -0,0 +1,14 @@
+SUMMARY = "AGL Instrument Cluster IPC library"
+DESCRIPTION = "AGL Instrument Cluster IPC is IPC framework for the AGL Instrument Cluster API.\
+ This library was contributed by four EG member company."
+HOMEPAGE = "https://confluence.automotivelinux.org/display/IC"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://git.automotivelinux.org/src/libcluster-ipc;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "464ed5a672700436a1cb89d41afe8c088d2f3c5b"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
diff --git a/meta-agl-ic-container/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend b/meta-agl-ic-container/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
new file mode 100644
index 00000000..13f85b59
--- /dev/null
+++ b/meta-agl-ic-container/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
@@ -0,0 +1,8 @@
+# Disable LTTng dependencies when building for container guest to avoid
+# lttng-modules being pulled in as a dependency.
+LTTNGUST:aglcontainerguest = ""
+LTTNGTOOLS:aglcontainerguest = ""
+LTTNGMODULES:aglcontainerguest = ""
+
+# Similarly, disable perf since it builds out of the kernel source tree.
+PERF:aglcontainerguest = ""
diff --git a/meta-agl-ic-container/recipes-core/systemd/systemd-netif-config/20-wired.network b/meta-agl-ic-container/recipes-core/systemd/systemd-netif-config/20-wired.network
new file mode 100644
index 00000000..abd371bd
--- /dev/null
+++ b/meta-agl-ic-container/recipes-core/systemd/systemd-netif-config/20-wired.network
@@ -0,0 +1,6 @@
+[Match]
+Name=eth0
+
+[Network]
+DHCP=ipv4
+
diff --git a/meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb b/meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb
new file mode 100644
index 00000000..0714f62b
--- /dev/null
+++ b/meta-agl-ic-container/recipes-core/systemd/systemd-netif-config_0.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Systemd network interface configuration"
+DESCRIPTION = "Systemd network interface configuration \
+ "
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = " \
+ file://20-wired.network \
+ "
+
+do_install() {
+ install -D -m0644 ${WORKDIR}/20-wired.network ${D}${sysconfdir}/systemd/network/20-wired.network
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FILES:${PN} = "\
+ ${sysconfdir}/systemd/network/* \
+"